Opened 6 years ago

Closed 6 years ago

#46121 closed defect (duplicate)

llvm-3.5 links with libedit but does not declare a dependency on it

Reported by: yarrgk@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: llvm-3.5

Description (last modified by ryandesign (Ryan Schmidt))

I just installed Xcode 6.1.1 on mac OS 10.9. My command line tools are for 6.1.1 and 10.9 and according to the apple dev site, they were updated Dec 2. I then used the OS 10.9 mac ports package to install macports.

I was trying to install py34-scipy and it crashed on the libgcc step. So I tried

sudo port install libgcc 

and that fails on the build step. I've attached the log.

:info:build collect2: error: ld terminated with signal 5 [Trace/BPT trap: 5]
:info:build dyld: Library not loaded: /opt/local/lib/libedit.0.dylib
:info:build   Referenced from: /opt/local/libexec/llvm-3.5/lib/libLTO.dylib
:info:build   Reason: image not found
:info:build make[3]: *** [libgcc_s.dylib] Error 1
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc49/libgcc/work/build/x86_64-apple-darwin13/libgcc'
:info:build make[2]: *** [all-stage1-target-libgcc] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc49/libgcc/work/build'
:info:build make[1]: *** [stage1-bubble] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc49/libgcc/work/build'
:info:build make: *** [bootstrap] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc49/libgcc/work/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc49/libgcc/work/build" && /usr/bin/make -j8 -w bootstrap 
:info:build Exit code: 2
:error:build org.macports.build for port libgcc returned: command execution failed
:debug:build Error code: CHILDSTATUS 8939 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)

Attachments (1)

main.log (5.4 KB) - added by yarrgk@… 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by yarrgk@…

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: libgcc install port removed
Owner: changed from macports-tickets@… to jeremyhu@…
Port: llvm-3.5 added; libgcc removed
Summary: libgcc -4.9.2_1 libgcc build fails libgcc_s.dylib not foundllvm-3.5 links with libedit but does not declare a dependency on it

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #46040.

Note: See TracTickets for help on using tickets.