Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#46136 closed defect (fixed)

poppler livecheck URL

Reported by: Schamschula (Marius Schamschula) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: haspatch Cc:
Port: poppler

Description (last modified by mf2k (Frank Schima))

poppler's livecheck fails as no useful version information, other than the current version is available on the homepage. The releases.html page does contain this information.

Note: The site does list poppler version 0.29.0 as the current stable release, which differs from previous even numbered releases (and the livecheck regex).

Attachments (1)

Portfile-poppler.diff (317 bytes) - added by Schamschula (Marius Schamschula) 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-poppler.diff added

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: devans@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 6 years ago by dbevans (David B. Evans)

Thanks for your report.

Yes, this is a policy change that was announced in the 0.28 release notice. In order to make releases more predictable and to decrease release overhead, stable releases will be made on a regular monthly basis with unstable code only available from git master. This is the first such stable release of the new system. The discussion leading up to this can be found in the thread rethinking poppler releases.

Fix for livecheck committed in r129095. Will commit updated version shortly after some testing.

comment:3 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

comment:4 in reply to:  2 Changed 6 years ago by dbevans (David B. Evans)

Replying to devans@…:

Will commit updated version shortly after some testing.

Testing shows that inkscape-0.48.5, inkscape-devel and pre-release versions of forthcoming inkscape-0.91 all fail to build with poppler 0.29.0 due to GfxColorSpace API changes introduced in this version. AFAICT, no other poppler dependents are effected.

I will defer the upgrade of poppler to 0.29.0 until the inkscape issues have been resolved.

Reported upstream and confirmed in Inkscape bug #1399811.

comment:5 Changed 6 years ago by dbevans (David B. Evans)

poppler updated to 0.29.0 in r129413, inkscape issues resolved.

Note: See TracTickets for help on using tickets.