Opened 5 years ago

Closed 5 years ago

#46137 closed defect (fixed)

pcre: Missing build dependency on autoconf and automake

Reported by: raimue (Rainer Müller) Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: haspatch Cc:
Port: pcre

Description

pcre tries to use aclocal-1.14 and autom4te in the configure process. The attached patch adds the required dependencies. Not increasing revision as it is only a build failure solved by adding new build dependencies.

You can see the failure with the old Portfile using trace mode: sudo port -vt configure pcre

Attachments (1)

patch-pcre-depbuild.diff (423 bytes) - added by raimue (Rainer Müller) 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by raimue (Rainer Müller)

Attachment: patch-pcre-depbuild.diff added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

I can’t actually reproduce this. sudo port -t configure pcre succeeds for me, and the trace library isn’t hiding anything related to Autotools:

Warning: The following existing files were hidden from the build system by trace mode:
  /opt/local/bin/ar
  /opt/local/bin/gmkdir
  /opt/local/bin/gsed
  /opt/local/bin/lipo
  /opt/local/bin/nm
  /opt/local/bin/nmedit
  /opt/local/bin/otool
  /opt/local/bin/ranlib
  /opt/local/bin/strip

But I see what the cause might be. Can you see if r129099 fixes it?

comment:2 Changed 5 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Sorry, my report was slightly wrong. The error actually only appears in the build phase:

$ svn info Portfile |grep Revision
Revision: 129093
$ sudo port -vt build
--->  Computing dependencies for pcre.
--->  Building pcre
make: Entering directory `/opt/local/var/macports/build/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/work/pcre-8.36'
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /opt/local/var/macports/build/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/work/pcre-8.36/missing aclocal-1.14 -I m4
/opt/local/var/macports/build/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/work/pcre-8.36/missing: line 81: aclocal-1.14: command not found
WARNING: 'aclocal-1.14' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make: *** [aclocal.m4] Error 127
make: Leaving directory `/opt/local/var/macports/build/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/work/pcre-8.36'
Command failed:  cd "/opt/local/var/macports/build/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/work/pcre-8.36" && /usr/bin/make -j8 -w all
Exit code: 2
Warning: The following existing file was hidden from the build system by trace mode:
  /opt/local/bin/aclocal-1.14
The following files would have been hidden from the build system by trace mode if they existed:
  /usr/gnu/include
  /usr/local/include
Error: Failed to build pcre: command execution failed
Error: See /opt/local/var/macports/logs/_Users_raimue_src_macports_trunk_dports_devel_pcre/pcre/main.log for details.
Error: Follow http://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port pcre failed

However, I can confirm that the change applied in r129099 did resolve the problem for me.

Note: See TracTickets for help on using tickets.