Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#46152 closed update (fixed)

update to massif-visualizer 0.4.0

Reported by: RJVB (René Bertin) Owned by: cjones051073 (Chris Jones)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: mkae (Marko Käning)
Port: massif-visualizer

Description

Here's an update for the massif-visualizer Portfile, including a patch that has become necessary.

Attachments (2)

massvisual.diff (1.3 KB) - added by RJVB (René Bertin) 4 years ago.
isnan-patch.diff (1.3 KB) - added by RJVB (René Bertin) 4 years ago.

Download all attachments as: .zip

Change History (16)

Changed 4 years ago by RJVB (René Bertin)

Attachment: massvisual.diff added

Changed 4 years ago by RJVB (René Bertin)

Attachment: isnan-patch.diff added

comment:1 Changed 4 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: jonesc@… removed
Owner: changed from macports-tickets@… to jonesc@…
Version: 2.3.3

comment:3 Changed 4 years ago by cjones051073 (Chris Jones)

Thanks for the update. Please feel free to commit them.

cheers Chris

comment:4 Changed 4 years ago by RJVB (René Bertin)

Thanks, but I don't have the powers to do that ... :)

comment:5 Changed 4 years ago by cjones051073 (Chris Jones)

Nor do I... Please feel free to bring this report to the attention of those that can...

comment:6 Changed 4 years ago by mkae (Marko Käning)

Done in r129222

Thanks!

comment:7 Changed 4 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

comment:8 Changed 4 years ago by mkae (Marko Käning)

Resolution: fixed
Status: closedreopened

This fails on all buildbots due to graphviz not being found there:

-- checking for modules 'libgvc;libcdt;libgraph;libpathplan'
--   package 'libgraph' not found
CMake Error at /opt/local/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message):
  Could NOT find GraphViz (missing: graphviz_LIBRARIES)
Call Stack (most recent call first):
  /opt/local/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:343 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindGraphViz.cmake:165 (find_package_handle_standard_args)
  CMakeLists.txt:18 (find_package)

(taken from Mavericks stdio output)

See e.g. this log for ML: http://build.macports.org/builders/buildports-mtln-x86_64/builds/19730

comment:9 Changed 4 years ago by RJVB (René Bertin)

The solution to that was given on macports-users (cannot recall nor hunt it down right now, sorry).

comment:10 Changed 4 years ago by mkae (Marko Käning)

I couldn't find it either...

comment:11 Changed 4 years ago by RJVB (René Bertin)

Here's what Ryan wrote about the issue - but for port:kgraphviewer :

libgraph was the old graphviz library, retired quite awhile ago now in favor of the libcgraph library. libgraph was deprecated in graphviz 2.30.0 in January 2013 and removed in graphviz 2.36.0 in January 2014. kgraphviewer will have to be rewritten to use libcgraph instead. Did you already check if a newer version of kgraphviewer exists with this change already made?

I just tried again: the port builds for me ...

comment:12 in reply to:  11 ; Changed 4 years ago by mkae (Marko Käning)

Replying to rjvbertin@…:

Here's what Ryan wrote about the issue - but for port:kgraphviewer : I just tried again: the port builds for me ...

On which OSX version? See above: all buildbots failed.

Last edited 4 years ago by mkae (Marko Käning) (previous) (diff)

comment:13 Changed 4 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed

Committed kgraphviewer (#46146) in r129386, to satisfy massif-visualizer.

comment:14 in reply to:  12 Changed 4 years ago by RJVB (René Bertin)

On which OSX version? See above: all buildbots failed.

I'm currently running 10.9.4 . [OT] I still need to check a few things before making 10.9 my primary OS, but apart from the all-screen fullscreen regression with "traditional" multiple screens which will keep annoying me, I am about ready to make the move. OT

Note: See TracTickets for help on using tickets.