Opened 6 years ago

Closed 2 years ago

#46186 closed defect (duplicate)

ocaml-extlib broken due to compiler version mismatch

Reported by: pbg@… Owned by: pmetzger (Perry E. Metzger)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: ocaml-extlib

Description

Using the latest ports for ocaml and ocaml-extlib produces the following error when I try to compile:

File "foo.ml", line 1:
Error: /opt/local/lib/ocaml/site-lib/extlib/extLib.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.

I note that ocaml-extlib has not been updated in a year, whereas the compiler has been updated within the last couple months. Thank you.

Change History (5)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mww@…
Port: ocaml-extlib added

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Owner: mww@… deleted
Status: newassigned

See #53012.

comment:3 Changed 2 years ago by pmetzger (Perry E. Metzger)

Owner: set to pmetzger

comment:4 Changed 2 years ago by pmetzger (Perry E. Metzger)

This almost certainly had nothing to do with the version of ocaml-extlib, but was rather because ocaml-extlib was compiled with an old compiler. Simply rebuilding the port would have fixed it. The report is also four years old. I'm inclined to close this.

Last edited 2 years ago by pmetzger (Perry E. Metzger) (previous) (diff)

comment:5 Changed 2 years ago by pmetzger (Perry E. Metzger)

Resolution: duplicate
Status: assignedclosed

This is now a duplicate of #56376

Note: See TracTickets for help on using tickets.