Opened 6 years ago

Last modified 6 years ago

#46216 assigned defect

gcc49: add patch 0049-Enable-SPE-AltiVec-generation

Reported by: intermediadc@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: mww@…
Port: gcc49

Description

Hello, after updating on gcc49_2 i cant build any more programs set for altivec I found a patch about look like gcc49 was missing it .

My configuration is powemac g5 quad 2.5 nvidia 7800gtx Thank you Luigi

https://github.com/openembedded/oe-core/blob/master/meta/recipes-devtools/gcc/gcc-4.9/0049-Enable-SPE-AltiVec-generation-on-powepc-linux-target.patch

Change History (5)

comment:1 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: mww@… added
Owner: changed from macports-tickets@… to larryv@…
Port: gcc49 added
Status: newassigned
Version: 2.3.3

That patch only makes a difference with --target=powerpc-linux, which is not applicable here.

Could you elaborate on your problem? What was the last version of MacPorts’ GCC that could handle AltiVec?

comment:2 in reply to:  1 ; Changed 6 years ago by intermediadc@…

Replying to larryv@…:

That patch only makes a difference with --target=powerpc-linux, which is not applicable here.

Could you elaborate on your problem? What was the last version of MacPorts’ GCC that could handle AltiVec?

Exactly if i try to buid something that need altivec in souces the gcc exit with an error

An example:

dct_altivec.c:74:5: note: in expansion of macro 'VEC_S16'
     VEC_S16 (13623, 18895, 17799, 16019, 13623, 16019, 17799, 18895);
     ^
idct_altivec.c:74:5: error: can't convert between vector values of different size
make[4]: *** [libmpeg2arch_la-idct_altivec.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

It build without problems with gcc 4.2 and gcc 4.3 and gcc 4.6 from macports .

Sorry i if was thinking the linux patch can help the macports too but was the first example where the gcc4.9 fail with altivec that i was find

Thank you Luigi

Last edited 6 years ago by intermediadc@… (previous) (diff)

comment:3 in reply to:  2 Changed 6 years ago by larryv (Lawrence Velázquez)

Replying to intermediadc@…:

Exactly if i try to buid something that need altivec in souces the gcc exit with an error

An example:

dct_altivec.c:74:5: note: in expansion of macro 'VEC_S16'
     VEC_S16 (13623, 18895, 17799, 16019, 13623, 16019, 17799, 18895);
     ^
idct_altivec.c:74:5: error: can't convert between vector values of different size
make[4]: *** [libmpeg2arch_la-idct_altivec.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Could you provide a minimal test case that exhibits the problem?

It build without problems with gcc 4.2 and gcc 4.3 and gcc 4.6 from macports .

What about gcc47 or gcc48?

comment:4 Changed 6 years ago by intermediadc@…

Umm sorry i dont know what you means for test case , my english is bit limited .. sorry if you need the link for the program that im try to build and fail on gcc49_2.x it is

https://github.com/FrodeSolheim/fs-uae

Here is the proof it was perfectly with altivec support on powermac g5 with old versions of gcc. http://i1249.photobucket.com/albums/hh511/tlosm/p5ufsuae_zps5101e969.jpg

About gcc48 im try to build it from mac ports right now but some times it fail because my interent connection is the worst in the world ...

Luigi

comment:5 in reply to:  4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Summary: 0049-Enable-SPE-AltiVec-generationgcc49: add patch 0049-Enable-SPE-AltiVec-generation

Replying to intermediadc@…:

Umm sorry i dont know what you means for test case , my english is bit limited .. sorry if you need the link for the program that im try to build and fail on gcc49_2.x it is

https://github.com/FrodeSolheim/fs-uae

By "test case", he means: provide the smallest program that demonstrates the problem.

Here is the proof it was perfectly with altivec support on powermac g5 with old versions of gcc. http://i1249.photobucket.com/albums/hh511/tlosm/p5ufsuae_zps5101e969.jpg

Right, and you previously said that gcc42, gcc43 and gcc46 from MacPorts worked, and Larry asked you to please try gcc47 and gcc48 as well. You could also try gcc5.

About gcc48 im try to build it from mac ports right now but some times it fail because my interent connection is the worst in the world ...

An internet connection should not be required to build gcc48, once the gcc48 distfile has been downloaded, of course.

Note: See TracTickets for help on using tickets.