Opened 6 years ago

Closed 6 years ago

#46248 closed defect (fixed)

Cockatrice: fails to build for OSX<10.9

Reported by: mkae (Marko Käning) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: Cockatrice

Description

The port fails to build on SL, L & ML buildbots:

cd /opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/common/pb && /usr/bin/g++-4.2   -DSFMT_MEXP=19937 -pipe -Os -arch x86_64  -s -O2 -arch x86_64 -mmacosx-version-min=10.6 -I/opt/local/include -I/opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/common/pb    -o CMakeFiles/cockatrice_protocol.dir/command_change_zone_properties.pb.cc.o -c /opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/common/pb/command_change_zone_properties.pb.cc
In file included from /opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/oracle/src/oracleimporter.h:6,
                 from /opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/oracle/src/oraclewizard.cpp:8:
/opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/oracle/../cockatrice/src/carddatabase.h:121: error: expected ‘,’ or ‘...’ before ‘>’ token
/opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/oracle/../cockatrice/src/carddatabase.h:121: error: wrong number of template arguments (1, should be 2)
/opt/local/include/QtCore/qdatastream.h:67: error: provided for ‘template<class Key, class T> class QMap’
/opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/oracle/../cockatrice/src/carddatabase.h:121: error: default argument missing for parameter 14 of ‘CardInfo::CardInfo(CardDatabase*, const QString&, bool, const QString&, const QString&, const QString&, const QString&, const QStringList&, int, bool, int, const SetList&, QMap<QString, int>, int)’
make[2]: *** [oracle/CMakeFiles/oracle.dir/src/oracleimporter.cpp.o] Error 1
/opt/local/bin/cmake -E cmake_progress_report /opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release/CMakeFiles 
[ 39%] make[2]: *** [oracle/CMakeFiles/oracle.dir/src/oraclewizard.cpp.o] Error 1
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_mports_dports_games_Cockatrice/Cockatrice/work/Cockatrice-2014-06-25-Release'
make[1]: *** [oracle/CMakeFiles/oracle.dir/all] Error 2

Does this require blacklisting gcc-4.2 and depending on a newer gcc or clang?

Change History (6)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

This looks like https://github.com/Cockatrice/Cockatrice/issues/131, the fix for which was included in our previous version "0.0.1" but is not in our new (older) version "0.0.2". We could include that patch in our "0.0.2", or we could go back to our "0.0.1" and bump the epoch. Alternately, since much development seems to have happened in the repository since June, we could update to a newer commit.

comment:2 Changed 6 years ago by mkae (Marko Käning)

So, in that case I'd use a newer commit, hoping that it won't cause any checksum trouble again.

And I don't really want to use epoch... :)

comment:3 in reply to:  2 Changed 6 years ago by larryv (Lawrence Velázquez)

You could switch to using a date for version. That would actually have meaning, unlike the current made-up version numbers.

I don’t understand why people seem to prefer jumping through ridiculous hoops over using epoch. Using epoch along with a version that actually means something is much better than avoiding epoch and making up a version number that has no upstream meaning.

Last edited 6 years ago by larryv (Lawrence Velázquez) (previous) (diff)

comment:4 Changed 6 years ago by mkae (Marko Käning)

Well, I would like to avoid epoch as it is something which will stay forever in the portfile.

But I see your point that making up a non-existing version number is probably worse. :(

Too late though. I've increased the revision number now: r129573

comment:5 in reply to:  4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to mk@…:

So, in that case I'd use a newer commit, hoping that it won't cause any checksum trouble again.

The checksum mismatch was caused by Cockatrice moving from organization "Daenyth" to organization "Cockatrice" so as long as the developers of Cockatrice do not change their organization name again we should be fine.

Replying to larryv@…:

You could switch to using a date for version. That would actually have meaning, unlike the current made-up version numbers.

That would be good.

Replying to mk@…:

Well, I would like to avoid epoch as it is something which will stay forever in the portfile.

So what? So do many other lines.

Too late though. I've increased the revision number now: r129573

Thanks.

comment:6 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.