Opened 8 years ago

Closed 7 years ago

#46334 closed defect (duplicate)

ghostscript @9.10_2+x11: configure fails if wxWidgets is absent

Reported by: brookemgilbert@… Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: poorsod@…, takanori@…
Port: ghostscript

Description (last modified by larryv (Lawrence Velázquez))

Hi, on a fresh install of macports 2.3.3 following upgrade to Yosemite (10.10.1), Ghostscript was failing to build/install (but I found a workaround).

This appears to be a different problem from this other similar ticket #46332 on examination of the log files.

My output was...

$ sudo port clean ghostscript
--->  Cleaning ghostscript
$ sudo port install -d ghostscript
--->  Computing dependencies for ghostscript
--->  Fetching archive for ghostscript
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports. See this page for more information: <>
--->  Attempting to fetch ghostscript-9.10_2+x11.darwin_14.x86_64.tbz2 from
--->  Attempting to fetch ghostscript-9.10_2+x11.darwin_14.x86_64.tbz2 from
--->  Attempting to fetch ghostscript-9.10_2+x11.darwin_14.x86_64.tbz2 from
--->  Fetching distfiles for ghostscript
--->  Verifying checksums for ghostscript
--->  Extracting ghostscript
--->  Applying patches to ghostscript
--->  Configuring ghostscript
Error: org.macports.configure for port ghostscript returned: autoreconf failure: command execution failed
Please see the log file for port ghostscript for details:
To report a bug, follow the instructions in the guide:
Error: Processing of port ghostscript failed

The main.log is attached; of interest was:

:info:configure aclocal: error: aclocal: file '/opt/local/share/aclocal/wxwin.m4' does not exist
:info:configure autoreconf: aclocal failed with exit status: 1

Since wxwin.m4 is part of wxWidgets, I tried installing wxWidgets-3.0 manually. Then I tried again to install ghostscript and it worked just fine! So I guess that means ghostscript needs wxWidgets-3.0 but it isn't identified as a dependency in the ports tree.

I can replicate the failure by uninstalling ghostscript and wxWidgets-3.0, then trying to re-install ghostscript.


Attachments (1)

ghostscript_main.log (74.1 KB) - added by brookemgilbert@… 8 years ago.
Ghostscript main.log (failing)

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by brookemgilbert@…

Attachment: ghostscript_main.log added

Ghostscript main.log (failing)

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Owner: changed from macports-tickets@… to takanori@…
Port: ghostscript added
Summary: Ghostscript build failure on Yosemiteghostscript @9.10_2+x11: configure fails if wxWidgets is absent

comment:2 Changed 8 years ago by poorsod@…

Cc: poorsod@… added

Cc Me!

comment:3 Changed 8 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:4 Changed 8 years ago by mojca (Mojca Miklavec)

There is only one way I'm able to reproduce this problem:

sudo port install wxWidgets-3.0
sudo ln -s /opt/local/Library/Frameworks/wxWidgets.framework/Versions/wxWidgets/3.0/share/aclocal/wxwin.m4 /opt/local/share/aclocal/
sudo port -f deactivate wxWidgets-3.0
sudo port -v configure ghostscript

And then autotools complain because /opt/local/share/aclocal/wxwin.m4 points to a non-existing location. Not because ghostscript would need that file, but because autotools look into /opt/local/share/aclocal/ and fail when a "non-existing" file is there.

Please try to deactivate/uninstall wxWidgets-3.0, show the output of port select wxWidgets (make sure that none is active), make sure to delete a dangling symlink /opt/local/share/aclocal/wxwin.m4 and try again. I suspect that should work.

I'm inclined to close this ticket as invalid.

comment:5 Changed 8 years ago by mojca (Mojca Miklavec)

Cc: takanori@… added; mojca@… removed
Owner: changed from takanori@… to mojca@…
Version: 2.3.3

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #47755.

Note: See TracTickets for help on using tickets.