Opened 5 years ago

Closed 5 years ago

#46376 closed defect (duplicate)

ImageMagick cannot be built while cryptlib is active

Reported by: barnstorming92@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: ImageMagick

Description

The build fails with the error

:notice:configure --->  Configuring ImageMagick
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing proc-pre-org.macports.configure-configure-0
:error:configure ImageMagick cannot be built while cryptlib is active.
:error:configure Please deactivate cryptlib and try again.
:error:configure You can reactivate cryptlib again later.
:error:configure org.macports.configure for port ImageMagick returned: cryptlib is active
:debug:configure Error code: NONE
:debug:configure Backtrace: cryptlib is active

Even manually trying to deactivate cryptlib failed itself, main.log a provided.

Change History (1)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Port: ImageMagick added; cryptlib removed
Resolution: duplicate
Status: newclosed
Summary: Failed to install ImageMagickImageMagick cannot be built while cryptlib is active

Duplicate of #46375.

Note: See TracTickets for help on using tickets.