Opened 3 years ago

Closed 2 years ago

#46378 closed update (fixed)

flex: update to 2.5.39

Reported by: rurban@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: ryandesign (Ryan Schmidt), kurthindenburg (Kurt Hindenburg)
Port: flex

Description (last modified by larryv (Lawrence Velázquez))

See http://patchwork.openembedded.org/patch/68029/

diff -bu ./Makefile.am~ ./Makefile.am
--- ./Makefile.am~	2014-03-26 13:46:44.000000000 +0100
+++ ./Makefile.am	2015-01-03 11:47:43.000000000 +0100
@@ -73,13 +73,13 @@
 	libmain.c \
 	libyywrap.c

-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
+libfl_la_LDFLAGS = -all-static -no-undefined -version-info @SHARED_VERSION_INFO@

 libfl_pic_la_SOURCES = \
 	libmain.c \
 	libyywrap.c

-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
+libfl_pic_la_LDFLAGS = -all-static -no-undefined -version-info @SHARED_VERSION_INFO@

 noinst_HEADERS = \
 	flexdef.h \
./conf.in

Change History (6)

comment:1 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Description modified (diff)
  • Owner changed from macports-tickets@… to mww@…
  • Port flex added

Why would we want this? Our flex port does not appear to install any shared libraries.

comment:2 Changed 3 years ago by rurban@…

Why would we want this?

flex is 2 versions behind. we have still 2.5.37. 2.5.39 requires now this automake patch to compile to static libs only.

Our flex port does not appear to install any shared libraries.

Yes. That's why we need this patch. Upstream also.

flex cannot be used as shared lib by design on most platforms. yylex is always external (user-provided), and only some systems allow unresolved symbols in shared libs.

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Summary changed from flex-2.5.39 needs -all-static to flex: update to 2.5.39
  • Type changed from defect to update

flex is 2 versions behind. we have still 2.5.37. 2.5.39 requires now this automake patch to compile to static libs only.

So our current flex 2.5.37 works fine, but you would like us to update to 2.5.39, which doesn't work unless it's patched. I propose this: report this problem to the developers of flex so that they can fix it in the appropriate way (because I'm not sure I'm qualified to judge whether the fix you have proposed is the correct one). I see one report about this in the flex bug tracker already, but the fix proposed there is different. When the developers release a new version of flex that once again works on OS X, then we will update the port to that version.

comment:4 Changed 2 years ago by kurthindenburg (Kurt Hindenburg)

  • Cc khindenburg@… added

Cc Me!

comment:5 follow-up: Changed 2 years ago by kurthindenburg (Kurt Hindenburg)

2.6.0 was just released which reports to fix this issue.

comment:6 in reply to: ↑ 5 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from new to closed

Replying to khindenburg@…:

2.6.0 was just released which reports to fix this issue.

r142999

Note: See TracTickets for help on using tickets.