Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#46450 closed defect (fixed)

p5-html-mason: upgrade, remove support for Apache 1, make it work with multiple versions of Perl

Reported by: mojca (Mojca Miklavec) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: dbevans (David B. Evans)
Port: p5-html-mason p5-http-server-simple-mason p5-masonx-request-withapachesession

Description

I'm attaching a patch to upgrade p5-html-mason. The tests set succeeds for 5.16, but there are some problems:

  • Is dependency on mod_perl[2] needed?
  • Can we drop support for mod_perl (Apache 1)
  • I can remove dependency on mod_perl2, then p5.20-html-mason builds ok, but it tries to install everything for 5.16 instead of 5.20

See also #42582

Attachments (1)

p5-html-mason.1.56.diff (1.8 KB) - added by mojca (Mojca Miklavec) 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by mojca (Mojca Miklavec)

Attachment: p5-html-mason.1.56.diff added

comment:1 Changed 6 years ago by mojca (Mojca Miklavec)

Port: p5-masonx-request-withapachesession added

comment:2 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

While p5-html-mason and friends may be used with mod_perl, mod_perl2, there is no requirement to do so. It works equally well in CGI web applications and even as a stand alone templating solution for non-web applications. No direct dependency on mod_perl or libapreq for build or test. The mod_perl variants are, therefore, unnecessary and just add confusion when implementing multiple perl support.

Support for 5.18 5.20 added in r132728 and +mod_perl +mod_perl2 variants removed. Support for 5.18 5.20 added to dependents in r132729, r132730.

Last edited 6 years ago by dbevans (David B. Evans) (previous) (diff)

comment:3 Changed 6 years ago by mojca (Mojca Miklavec)

Thanks a lot for this one.

Note: See TracTickets for help on using tickets.