Opened 5 years ago

Closed 4 years ago

#46515 closed defect (fixed)

naturaldocs' installation locations vary depending on perl5's installed variant

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: naturaldocs

Description

naturaldocs' installation locations vary depending on perl5's installed variant. For example, on my system, with perl5 installed with the +perl5_20 variant, naturaldocs installed:

/opt/local/lib/perl5/vendor_perl/5.20/NaturalDocs -> /opt/local/lib/NaturalDocs-1.5/Modules/NaturalDocs

This breaks ports expecting naturaldocs' files to be in a particular location. See comment:ticket:46363:2

The port should be updated to depend explicitly on perl5.16 and to install its symlink pointing to the perl5.16 module directory. I would not suggest adding perl variants because that too would break dependents of naturaldocs, unless those dependents were to also adopt the same variants (though that would also be an acceptable solution).

Change History (2)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Owner: changed from landonf@… to ryandesign@…
Status: newassigned

#49857 was caused by this problem.

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.