Opened 6 years ago

Closed 6 years ago

#46612 closed defect (duplicate)

Error: org.macports.build for port graphviz returned: command execution failed

Reported by: tanertekin@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: leeawalsh@…, mtalexander (Mike Alexander)
Port: graphviz

Description (last modified by ryandesign (Ryan Schmidt))

Hi,

I want to install the program. After making the necessary operations sudo port install gnuradio When I wrote the command terminal ,I'm getting the error

Error: org.macports.build returned for graphviz port : command execution failed
Taner-MacBook-Pro:~ tanertekin$ sudo port install gnuradio
Password:
--->  Computing dependencies for gnuradio
--->  Dependencies to be installed: graphviz gsl jack libsamplerate libsndfile flac libogg libvorbis libxslt readline libsdl xorg-libXrandr xorg-randrproto log4cpp orc portaudio py27-cheetah py27-lxml py27-opengl py27-Pillow lcms openjpeg py27-opengl-accelerate py27-pygtk atk gtk2 gdk-pixbuf2 shared-mime-info hicolor-icon-theme xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-inputproto xorg-libXinerama xorg-xineramaproto libglade2 py27-gobject py27-pyqt4 dbus-python27 dbus dbus-glib py27-sip qt4-mac libmng py27-pyqwt qwt52 py27-sphinx py27-docutils py27-roman py27-jinja2 py27-pygments sphinx_select py27-wxpython-3.0 wxPython-3.0 wxWidgets_select qwtplot3d uhd gzip libusb xmlto coreutils docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl findutils fop getopt libpaper
--->  Building graphviz
Error: org.macports.build for port graphviz returned: command execution failed
Error: Failed to install graphviz
Please see the log file for port graphviz for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/main.log
Error: The following dependencies were not installed: graphviz gsl jack libsamplerate libsndfile flac libogg libvorbis libxslt readline libsdl xorg-libXrandr xorg-randrproto log4cpp orc portaudio py27-cheetah py27-lxml py27-opengl py27-Pillow lcms openjpeg py27-opengl-accelerate py27-pygtk atk gtk2 gdk-pixbuf2 shared-mime-info hicolor-icon-theme xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-inputproto xorg-libXinerama xorg-xineramaproto libglade2 py27-gobject py27-pyqt4 dbus-python27 dbus dbus-glib py27-sip qt4-mac libmng py27-pyqwt qwt52 py27-sphinx py27-docutils py27-roman py27-jinja2 py27-pygments sphinx_select py27-wxpython-3.0 wxPython-3.0 wxWidgets_select qwtplot3d uhd gzip libusb xmlto coreutils docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl findutils fop getopt libpaper
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gnu radio failed

What can I do? Thank you advanced.

Attachments (1)

graphviz_main.log (158.0 KB) - added by leeawalsh@… 6 years ago.
graphviz main log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: graphviz added

Please clean graphviz and try again. If it fails again, please attach the main.log file mentioned in your error message, so that we can see why it failed.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

This could be a duplicate of #46582 but without a main.log file there's no way to know. So please attach your main.log file and then add a comment to let us know you've done that.

comment:3 in reply to:  2 Changed 6 years ago by leeawalsh@…

Replying to ryandesign@…:

This could be a duplicate of #46582 but without a main.log file there's no way to know. So please attach your main.log file and then add a comment to let us know you've done that.

I'm having the problem too and will attach my log file. I just upgraded from 10.9 Mavericks to 10.10 Yosemite. Reinstalled most of my ports and graphviz is the only troublesome port so far.

~$ sudo port clean graphviz
Password:
--->  Cleaning graphviz
~$ sudo port install graphviz
--->  Computing dependencies for graphviz
--->  Fetching archive for graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://packages.macports.org/graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/graphviz
--->  Fetching distfiles for graphviz
--->  Verifying checksums for graphviz
--->  Extracting graphviz
--->  Configuring graphviz
--->  Building graphviz
Error: org.macports.build for port graphviz returned: command execution failed
Please see the log file for port graphviz for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_graphviz/graphviz/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port graphviz failed
~$ cp /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_graphviz/graphviz/main.log ./graphviz_main.log
Last edited 6 years ago by leeawalsh@… (previous) (diff)

Changed 6 years ago by leeawalsh@…

Attachment: graphviz_main.log added

graphviz main log

comment:4 Changed 6 years ago by leeawalsh@…

This is strange: I ran into the problem with graphviz while installing fish, so without any particular reason I tried the following right after posting the graphviz main.log, and it worked:

~$ sudo port clean fish
Password:
--->  Cleaning fish
~$ sudo port clean graphviz
--->  Cleaning graphviz
~$ sudo port install fish
--->  Computing dependencies for fish
--->  Dependencies to be installed: graphviz
--->  Fetching archive for graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://packages.macports.org/graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/graphviz
--->  Attempting to fetch graphviz-2.38.0_0+pangocairo+x11.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/graphviz
--->  Fetching distfiles for graphviz
--->  Verifying checksums for graphviz
--->  Extracting graphviz
--->  Configuring graphviz
--->  Building graphviz
--->  Staging graphviz into destroot
--->  Installing graphviz @2.38.0_0+pangocairo+x11
--->  Activating graphviz @2.38.0_0+pangocairo+x11
--->  Cleaning graphviz
--->  Fetching archive for fish
--->  Attempting to fetch fish-2.1.0_1.darwin_14.x86_64.tbz2 from http://packages.macports.org/fish
--->  Attempting to fetch fish-2.1.0_1.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/fish
--->  Attempting to fetch fish-2.1.0_1.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/fish
--->  Fetching distfiles for fish
--->  Verifying checksums for fish
--->  Extracting fish
--->  Applying patches to fish
--->  Configuring fish
--->  Building fish
--->  Staging fish into destroot
--->  Installing fish @2.1.0_1
--->  Activating fish @2.1.0_1

I honestly don't know what changed between the two runs. Happy to provide any other information if it can help.

comment:5 Changed 6 years ago by mtalexander (Mike Alexander)

This is happening because of a version skew between the automake and libtool ports. The libtool port installs /opt/local/share/libtool/Makefile.in which seems to be used to create the makefile for libltdl in graphviz. Macports contains version 1.15 of automake and version 2.4.4 of libtool which is compatible with version 1.14.1 of automake. I'm not sure exactly how this all works (Gnu autotools is not easy to understand) but upgrading libtool to version 2.4.5 fixes the problem. The patch to do this is

--- /Users/mta/macports/macports-trunk/dports/devel/libtool/Portfile	2014-12-08 17:21:47.000000000 -0500
+++ /Volumes/Gravenhurst/Users/mta/macports/macports-trunk/dports/devel/libtool/Portfile	2015-02-03 00:40:04.000000000 -0500
@@ -4,7 +4,7 @@
 PortSystem          1.0
 
 name                libtool
-version             2.4.4
+version             2.4.5
 categories          devel sysutils
 platforms           darwin freebsd
 # Scripts are GPL-2+, libltdl is LGPL-2+, but all parts that tend to be
@@ -27,8 +27,8 @@
 depends_run         bin:gm4:m4
 
 master_sites        gnu
-checksums           rmd160  5dd509e9815171cbef1c8496976d0db6bef68f63 \
-                    sha256  159d4e20c201f929e3562536d3ae6b5e605403fa4bb4e72ef197a4e162c3fedf
+checksums           rmd160  fc319ae4cd5ea8da28b46448b501b4533b9c143e \
+                    sha256  509cb49c7de14ce7eaf88993cf09fd4071882699dfd874c2e95b31ab107d6987
 
 platform darwin {
     configure.env   GREP=/usr/bin/grep \

comment:6 in reply to:  5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: leeawalsh@… mta@… added

Replying to leeawalsh@…:

I'm having the problem too and will attach my log file.

Yes, that is #46582.

Replying to leeawalsh@…:

This is strange: I ran into the problem with graphviz while installing fish, so without any particular reason I tried the following right after posting the graphviz main.log, and it worked:

I honestly don't know what changed between the two runs. Happy to provide any other information if it can help.

Yes, I have also seen the problem be intermittent on my system, which I am not able to explain either.

Replying to mta@…:

This is happening because of a version skew between the automake and libtool ports. The libtool port installs /opt/local/share/libtool/Makefile.in which seems to be used to create the makefile for libltdl in graphviz. Macports contains version 1.15 of automake and version 2.4.4 of libtool which is compatible with version 1.14.1 of automake. I'm not sure exactly how this all works (Gnu autotools is not easy to understand) but upgrading libtool to version 2.4.5 fixes the problem. The patch to do this is

Yes, I also do not understand autotools fully. The request to update libtool to 2.4.5 is #46635.

I am still waiting to receive the main.log from the reporter tanertekin so that I can either close this ticket as a duplicate or address the issue if it is a different issue.

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

I'm going to assume this was a duplicate of #46582, which is now fixed. Please run "sudo port clean graphviz" and "sudo port selfupdate", then try again.

Note: See TracTickets for help on using tickets.