Opened 6 years ago

Closed 6 years ago

#46648 closed defect (invalid)

destroot Command failed when "port install gnuplot"

Reported by: meju84@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: mojca (Mojca Miklavec)
Port: gnuplot

Description (last modified by ryandesign (Ryan Schmidt))

installing gnuplot isn't working

How i could start gnuplot for follwing errer?

Error: org.macports.destroot for port gnuplot returned: command execution failed

Attachments (1)

main.log (255.0 KB) - added by meju84@… 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by meju84@…

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: gnuplot destroot removed
Port: gnuplot added
Priority: HighNormal

The bizarre errors in your log suggest that you have somehow replaced the /usr/bin/install program with something else -- perhaps an INSTALL text document from some program? Please restore /usr/bin/install from your backups, or reinstall the correct version. (I guess it's part of the Xcode command line tools, so you could try downloading that installer from the Apple developer site and running it.)

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Indeed it looks like your /usr/bin/install is a copy of gnuplot's own INSTALL file. Do you have any idea how that could have happened?

comment:3 Changed 6 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

If you need further help resolving this issue, please ask on the macports-users mailing list, referencing this issue. I'm closing the bug report now, because it is not a bug in MacPorts; it is a misconfiguration of your machine.

Note: See TracTickets for help on using tickets.