Opened 6 years ago

Closed 6 years ago

#46682 closed defect (duplicate)

libpcl @1.7.1: error: no member named 'at' in namespace 'pcl::io::ply'

Reported by: my@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: yosemite Cc: luminans@…, Veence (Vincent), davidwalton3142@…
Port: libpcl

Description

I tried to install libpcl and everything went well but the last step. Hence, pasting the error info below:

$ sudo port install libpcl
Password:
--->  Computing dependencies for libpcl
--->  Fetching archive for libpcl
--->  Attempting to fetch libpcl-1.7.1_0.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/libpcl
--->  Attempting to fetch libpcl-1.7.1_0.darwin_14.x86_64.tbz2 from http://packages.macports.org/libpcl
--->  Attempting to fetch libpcl-1.7.1_0.darwin_14.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/libpcl
--->  Fetching distfiles for libpcl
--->  Verifying checksums for libpcl
--->  Extracting libpcl
--->  Configuring libpcl
--->  Building libpcl
Error: org.macports.build for port libpcl returned: command execution failed
Please see the log file for port libpcl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_libpcl/libpcl/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port libpcl failed

Attached is the log file: main.log

Attachments (1)

main.log (143.8 KB) - added by my@… 6 years ago.
the log file

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by my@…

Attachment: main.log added

the log file

comment:1 Changed 6 years ago by davidwalton3142@…

Cc: davidwalton3142@… added

Cc Me!

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: yosemite added; Yosemite removed
Resolution: duplicate
Status: newclosed
Summary: Failed in building libpcl on Yosemitelibpcl @1.7.1: error: no member named 'at' in namespace 'pcl::io::ply'

Duplicate of #45340.

Note: See TracTickets for help on using tickets.