Opened 4 years ago

Closed 4 years ago

#46709 closed defect (worksforme)

Failed to configure ffmpeg

Reported by: wangsix@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: ffmpeg

Description

OS X 10.9.5

Anonymous:~User$ sudo port install -v -f ffmpeg
--->  Computing dependencies for ffmpeg
--->  Fetching archive for ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://packages.macports.org/ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/ffmpeg
--->  Fetching distfiles for ffmpeg
--->  Verifying checksums for ffmpeg
--->  Extracting ffmpeg
--->  Applying patches to ffmpeg
--->  Configuring ffmpeg

Error: Failed to configure ffmpeg, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/work/ffmpeg-2.5.3/config.log
Error: org.macports.configure for port ffmpeg returned: configure failure: command execution failed
Please see the log file for port ffmpeg for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/main.log

Attachments (3)

main.log (104.8 KB) - added by wangsix@… 4 years ago.
main.log
config.log (372.1 KB) - added by wangsix@… 4 years ago.
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/work/ffmpeg-2.5.3/config.log
main 2.log (104.5 KB) - added by wangsix@… 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by wangsix@…

Attachment: main.log added

main.log

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to devans@…
Status: newassigned
Version: 2.3.3

It's saying that gnutls is not being recognized using pkg-config. The log also says that macports thinks that gnutls is installed.

However, I can't reproduce the problem here so may be something specific to your installation.

/opt/local/var/macports/build/_opt_macports_trunk_dports_multimedia_ffmpeg/ffmpeg/work/config.log should show more detail about what the problem is. Please attach.

Also please make sure that gnutls is properly installed and that /opt/local/lib/pkgconfig/gnutls.pc exists.

What does

pkg-config --libs --cflags gnutls

return?

Last edited 4 years ago by dbevans (David B. Evans) (previous) (diff)

Changed 4 years ago by wangsix@…

Attachment: config.log added

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/work/ffmpeg-2.5.3/config.log

comment:2 Changed 4 years ago by wangsix@…

pkg-config --libs --cflags gnutls

returns

Package zlib was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib.pc'
to the PKG_CONFIG_PATH environment variable
Package 'zlib', required by 'gnutls', not found

and /opt/local/lib/pkgconfig/gnutls.pc exists.

Thank you, the config.log file is attached.

comment:3 Changed 4 years ago by dbevans (David B. Evans)

Is zlib installed?

$ port installed zlib
The following ports are currently installed:
  zlib @1.2.8_0 (active)

and /opt/local/lib/pkgconfig/zlib.pc ?

comment:4 Changed 4 years ago by dbevans (David B. Evans)

Note that config.log also shows the problem is missing zlib.

check_pkg_config gnutls gnutls/gnutls.h gnutls_global_init
pkg-config --exists --print-errors gnutls
Package zlib was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib.pc'
to the PKG_CONFIG_PATH environment variable
Package 'zlib', required by 'gnutls', not found
ERROR: gnutls not found using pkg-config

comment:5 Changed 4 years ago by wangsix@…

Anonymous:~ User$ sudo port installed zlib
The following ports are currently installed:
  zlib @1.2.8_0+universal (active)

but /opt/local/lib/pkgconfig/zlib.pc does not exist. After reinstall via

sudo port install zlib

The file zlib.pc exists.

Then retry install ffmpeg via

sudo port clean ffmpeg
sudo port install ffmpeg

get the following

--->  Computing dependencies for ffmpeg
--->  Fetching archive for ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://packages.macports.org/ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/ffmpeg
--->  Attempting to fetch ffmpeg-2.5.3_0+gpl2+x11.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/ffmpeg
--->  Fetching distfiles for ffmpeg
--->  Verifying checksums for ffmpeg
--->  Extracting ffmpeg
--->  Applying patches to ffmpeg
--->  Configuring ffmpeg
Error: Failed to configure ffmpeg, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/work/ffmpeg-2.5.3/config.log
Error: org.macports.configure for port ffmpeg returned: configure failure: command execution failed
Please see the log file for port ffmpeg for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_ffmpeg/ffmpeg/main.log

The new main.log is attached. (main 2.log)

Changed 4 years ago by wangsix@…

Attachment: main 2.log added

comment:6 Changed 4 years ago by dbevans (David B. Evans)

Per the log, error this time is

:info:configure ERROR: libass not found using pkg-config

So you may need to do the same with it.

However, this all looks like something is definitely not right with your ports installation. These errors are saying the the ports in question are installed but not all expected files are available (.pc files for instance).

If you continue to run into this sort of problem, you may need to remove MacPorts completely and reinstall to make sure you have a consistent installation.

Have you recently upgraded your OS from another version? If so did you follow the Migration instructions?

comment:7 Changed 4 years ago by wangsix@…

After repeat the similar process. Finally the ffmpeg is installed.

comment:8 Changed 4 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.