Opened 6 years ago

Closed 5 years ago

#46731 closed defect (worksforme)

variant weirdness doing incremental destroot of port:pulseaudio

Reported by: RJVB (René Bertin) Owned by: Ionic (Mihai Moldovan)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: Ionic (Mihai Moldovan)
Port: pulseaudio

Description

I'm tinkering with the pulseaudio 5.0 code, so I do my usual dance of making point edits in the Portfile (e.g. adding a patch file) and then rewinding the state in .macports.pulseaudio.state to be able to do a port destroot and have it do a build first.

Here's what I see:

#> port -nvko -d destroot pulseaudio +jack+openssl configure.optflags="-O3 -march=native -g"
DEBUG: Changing to port directory: /Volumes/Debian/MP9/site-ports/audio/pulseaudio
DEBUG: OS darwin/13.4.0 (Mac OS X 10.9) arch i386
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: adding the default universal variant
DEBUG: Executing variant x11 provides x11
DEBUG: Executing variant jack provides jack
DEBUG: Executing variant openssl provides openssl
DEBUG: Running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Finished running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Finished running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Privilege de-escalation not attempted as not running as root.
Error: Requested variants "+jack+openssl+x11" do not match original selection "+jack+openssl".
Please use the same variants again, perform 'port clean pulseaudio' or specify the force option (-f).
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port pulseaudio failed
Exit 1

OK, let's add the (default!) X11 variant even though it's not listed as a variant in the state file:

#> port -nvko -d destroot pulseaudio +jack+openssl+x11 configure.optflags="-O3 -march=native -g"
DEBUG: Changing to port directory: /Volumes/Debian/MP9/site-ports/audio/pulseaudio
DEBUG: OS darwin/13.4.0 (Mac OS X 10.9) arch i386
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: adding the default universal variant
DEBUG: Executing variant x11 provides x11
DEBUG: Executing variant jack provides jack
DEBUG: Executing variant openssl provides openssl
DEBUG: Running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Finished running callback portconfigure::add_automatic_compiler_dependencies
DEBUG: Running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Finished running callback portbuild::add_automatic_buildsystem_dependencies
DEBUG: Privilege de-escalation not attempted as not running as root.
Error: Requested variants "+jack+openssl+x11" do not match original selection "+jack+openssl".
Please use the same variants again, perform 'port clean pulseaudio' or specify the force option (-f).
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port pulseaudio failed
Exit 1

...There's a hole in my bucket, dear Lisa...

Attachments (1)

Portfile (4.2 KB) - added by RJVB (René Bertin) 6 years ago.
current Portfile

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by RJVB (René Bertin)

Attachment: Portfile added

current Portfile

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 6 years ago by larryv (Lawrence Velázquez)

It looks to me like the state file remembered +jack+openssl as the variant selection. You tried twice to run port destroot pulseaudio +jack+openssl+x11 (+x11 was implicit in the first invocation), and base rejected you twice due to mismatched variants. Which sounds correct.

So what behavior are you expecting? What exactly did you do prior to the initial port destroot?

comment:3 Changed 6 years ago by RJVB (René Bertin)

If memory serves me well, I had done a port -no upgrade after editing the Portfile (incl. bumping the revision) and editing the state file so that the process would start at the configure step. My idea was that using upgrade would save me from having to type in the currently active variants. My memory is a bit hazy on this because I had to interrupt the build process at some point, then my X server started acting up (I like working in an xterm :)), and when I finally was back in business I got the errors shown above. I *am* sure that the initial command worked just fine.

I wonder if the previous build had not been +jack+openssl-x11 and the port upgrade messed up something. Or I simply forgot to add an explicit -x11 instead of copying the variants from the output of port installed pulseaudio.

comment:4 Changed 6 years ago by Ionic (Mihai Moldovan)

Cc: ionic@… added

comment:5 Changed 6 years ago by Ionic (Mihai Moldovan)

+x11 is likely also set as a default variant in variants.conf.

Is this really a bug, or can I close it as invalid?

comment:6 Changed 6 years ago by RJVB (René Bertin)

I'd have to look at that.

As far as I'm concerned you can close this as invalid or incomplete or whatever suits you. If ever I run into an issue again I'll open a new ticket, hopefully with more precise/complete information.

comment:7 Changed 6 years ago by dbevans (David B. Evans)

Owner: changed from devans@… to ionic@…

comment:8 Changed 5 years ago by Ionic (Mihai Moldovan)

Resolution: worksforme
Status: newclosed

Well, don't open a new ticket, just re-open this one.

But I don't see any reason for keeping it open if even you can't reproduce it.

Note: See TracTickets for help on using tickets.