Opened 6 years ago

Closed 6 years ago

#46852 closed defect (invalid)

apple-gcc42 Won't build on Mac OS X tiger

Reported by: dfifer19@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: apple-gcc42

Description (last modified by larryv (Lawrence Velázquez))

When I Do sudo port install git-core everything works but apple-gcc42 won't build how do I fix this? Below is what happens after I enter the command.

devin-fifers-imac:~ devinfifer$ sudo port install git-core
Password:
--->  Computing dependencies for git-core
--->  Dependencies to be installed: apple-gcc42
--->  Building apple-gcc42

Change History (6)

comment:1 Changed 6 years ago by dfifer19@…

This Is not a New Defect and Priority is Normal

comment:2 Changed 6 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Keywords: apple-gcc42 tiger git-core removed
Owner: changed from macports-tickets@… to jeremyhu@…
Port: apple-gcc42 added; git-core removed
Priority: HighNormal

Your ports tree is horribly out of date. The git-core port was renamed to git eight months ago.

Please run the following commands to try again:

$ sudo port clean apple-gcc42 git-core
$ sudo port -d selfupdate
$ sudo port install apple-gcc42 +bootstrap
$ sudo port -n upgrade --enforce-variants apple-gcc42 -bootstrap
$ sudo port install git-core

comment:3 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Probably duplicate of #46642. Please don’t open new tickets when existing tickets describe your problem.

comment:4 in reply to:  3 Changed 6 years ago by dfifer19@…

Resolution: duplicate
Status: closedreopened

Replying to larryv@…:

Probably duplicate of #46642. Please don’t open new tickets when existing tickets describe your problem.

It has been on this for the last hour and forty minutes what do I do? devin-fifers-imac:~ devinfifer$ sudo port install apple-gcc42 +bootstrap Password: ---> Computing dependencies for apple-gcc42 ---> Fetching archive for apple-gcc42 ---> Attempting to fetch apple-gcc42-5666.3_14+bootstrap.darwin_8.ppc.tbz2 from http://packages.macports.org/apple-gcc42 ---> Attempting to fetch apple-gcc42-5666.3_14+bootstrap.darwin_8.ppc.tbz2 from http://lil.fr.packages.macports.org/apple-gcc42 ---> Attempting to fetch apple-gcc42-5666.3_14+bootstrap.darwin_8.ppc.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/apple-gcc42 ---> Fetching distfiles for apple-gcc42 ---> Verifying checksums for apple-gcc42 ---> Extracting apple-gcc42 ---> Applying patches to apple-gcc42 ---> Configuring apple-gcc42 ---> Building apple-gcc42

comment:5 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Sounds like it's building. I suggest you use --verbose if you want more info, or you can tail -f the log file.

comment:6 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: invalid
Status: reopenedclosed

There’s no evidence here that anything is wrong. Compilers can take a long time to build. Like Jeremy said, request verbose output

$ sudo port -v install apple-gcc42

or debug output

$ sudo port -d install apple-gcc42

to verify that the build is not getting stuck.

Note: See TracTickets for help on using tickets.