Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#46874 closed defect (worksforme)

openssl @1.0.2.0 upgrade failure

Reported by: galgot@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: neverpanic (Clemens Lang), galgot@…
Port: openssl

Description (last modified by neverpanic (Clemens Lang))

Can't upgrade openssl in Mac OSX 10.8.5 .

Tried reinstalling Macport with : sudo port -f selfupdate . But no success.

this is the error message:

Error: org.macports.build for port openssl returned: command execution failed
Please see the log file for port openssl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/main.log
Error: Unable to upgrade port: 1

attached is the log file.

Any ideas ?

Thanks

Attachments (3)

main.log (32.8 KB) - added by galgot@… 6 years ago.
main2.log (46.8 KB) - added by galgot@… 6 years ago.
main3.log (144.6 KB) - added by galgot@… 6 years ago.

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by galgot@…

Attachment: main.log added

comment:1 Changed 6 years ago by neverpanic (Clemens Lang)

Cc: cal@… added
Description: modified (diff)
Owner: changed from macports-tickets@… to larryv@…
Port: openssl added

Please use WikiFormatting, preview your ticket, fill in the port field and Cc the maintainers, if any, when reporting bugs against ports.

Your log does not show a clean build. Please run sudo port clean openssl and try again. If it fails again, please attach the generated logfile.

comment:2 Changed 6 years ago by galgot@…

Cc: galgot@… added

Cc Me!

Changed 6 years ago by galgot@…

Attachment: main2.log added

comment:3 in reply to:  1 ; Changed 6 years ago by galgot@…

Replying to cal@…:

Please use WikiFormatting, preview your ticket, fill in the port field and Cc the maintainers, if any, when reporting bugs against ports.

Your log does not show a clean build. Please run sudo port clean openssl and try again. If it fails again, please attach the generated logfile.

Thanks for fast response. Did run sudo port clean openssl. then sudo port upgrade outdated, but gives me the same error. Attached the Log file as "main2.log". Sorry , don't know how modify the ticket to Cc the maintainers.

comment:4 in reply to:  3 ; Changed 6 years ago by neverpanic (Clemens Lang)

Replying to galgot@…:

Thanks for fast response. Did run sudo port clean openssl. then sudo port upgrade outdated, but gives me the same error. Attached the Log file as "main2.log".

Actually, that's a different error, and I think it's a duplicate of #46719. Can you clean again and re-try while appending build.jobs=1 to the command line?

Sorry , don't know how modify the ticket to Cc the maintainers.

Don't worry about it now, I've changed it for you.

Changed 6 years ago by galgot@…

Attachment: main3.log added

comment:5 in reply to:  4 Changed 6 years ago by galgot@…

Replying to cal@…:

Replying to galgot@…:

Thanks for fast response. Did run sudo port clean openssl. then sudo port upgrade outdated, but gives me the same error. Attached the Log file as "main2.log".

Actually, that's a different error, and I think it's a duplicate of #46719. Can you clean again and re-try while appending build.jobs=1 to the command line?

Sorry , don't know how modify the ticket to Cc the maintainers.

Don't worry about it now, I've changed it for you.

Thanks.

So i Cleaned again , sudo port clean openssl . then did sudo port upgrade outdated build.jobs=1 . It did "Error: Unable to upgrade port: 1 " again. Attached Log file as "main3.log".

comment:6 Changed 6 years ago by galgot@…

Mmmh Sorry forgot the "--" …

so did again sudo port upgrade openssl -- build.jobs=1 , but it failed again.

comment:7 Changed 6 years ago by neverpanic (Clemens Lang)

Googling suggests this might be due to outdated Xcode and/or Command Line Tools. Can you try updating them to the latest available version for your OS?

comment:8 in reply to:  7 Changed 6 years ago by galgot@…

Replying to cal@…:

Googling suggests this might be due to outdated Xcode and/or Command Line Tools. Can you try updating them to the latest available version for your OS?

Indeed updating Command Line Tools was needed ! It build Ok now. Thanks for your help, and sorry for the inconvenience.

comment:9 Changed 6 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: newclosed

No problem. Glad you got it fixed.

comment:10 Changed 6 years ago by jerryyhom

Is there any guidance as to which versions of Xcode or CLT do not work? Or can you point to what you googled?

comment:11 Changed 6 years ago by neverpanic (Clemens Lang)

I googled "error: invalid instruction mnemonic 'adoxq'" and a discussion on fink's mailing list came up.

comment:12 in reply to:  10 ; Changed 6 years ago by larryv (Lawrence Velázquez)

The issue (somehow) was probably that Xcode and the CLT were mismatched.

comment:13 in reply to:  12 Changed 6 years ago by galgot@…

Replying to larryv@…:

The issue (somehow) was probably that Xcode and the CLT were mismatched.

My Xcode version is 5.1.1 , I updated the CLT to the latest available version from the Xcode preferences , so I couldn't see what was the (non-working) version I had before updating...

Note: See TracTickets for help on using tickets.