Opened 6 years ago

Closed 6 years ago

#46879 closed defect (duplicate)

command execution failed when reinstalling octave with gl2ps

Reported by: rspinney20@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: octave

Description (last modified by ryandesign (Ryan Schmidt))

Hi,

I'm attempting to install octave on OSX 10.8.5

Salient facts:

  1. I had successfully installed octave with "sudo port install octave +atlas". It was working.
  2. I needed to use the fltk graphics interface (the gnuplot one doesn't support all the moving labels etc. fully) so I uninstalled octave, installed fltk (through macports), then reinstalled octave. This too worked and I was successfully plotting within FLTK GL windows.
  3. Miserably (I have no idea why these packages are not simply listed as dependencies), one cannot save figures with the fltk graphics interface without gl2ps being installed and it is not a dependency, so I uninstalled fltk and octave, installed gl2ps, installed fltk, but when I came to installed octave, I got an error:
--->  Building octave
Error: org.macports.build for port octave returned: command execution failed
Please see the log file for port octave for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port octave failed

Things I have tried:

  1. sudo port selfupdate
  2. sudo port upgrade outdated
  3. totally uninstalled macports (following instructions here (https://guide.macports.org/chunked/installing.macports.uninstalling.html), then started from scratch.

But after trying everything I still get the same error.

By a process of trial and error I get these results based on the permutations (of installations of gl2ps, fltk) I get

gl2ps: not installed
fltk: not installed
octave: builds!
gl2ps: installed
fltk: not installed
octave: builds
gl2ps: installed
fltk: not installed
octave: builds!
gl2ps: installed
fltk: installed
octave: build fails!

which would indicate that including gl2ps, as part of fltk, is what is causing trouble. But I need to save my figures! I don't see the point of being able to use the flexibility of the fltk graphing toolkit, but not be able to save the figures. Does anyone have any suggestions?

I attach the compressed main.log file

Thanks,

R.

Attachments (2)

main.log.tar.gz (118.5 KB) - added by rspinney20@… 6 years ago.
main2.log.tar.gz (109.9 KB) - added by rspinney20@… 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by rspinney20@…

Attachment: main.log.tar.gz added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: octave fltk gl2ps removed
Owner: changed from macports-tickets@… to michaelld@…

comment:2 Changed 6 years ago by michaelld (Michael Dickens)

I just pushed r133004, which might fix this issue. At a minimum, it -correctly- adds back in the dependencies you're working with in the variant +glgui. I encourage you to do:

sudo port selfupdate

and then experiment with updating octave (which by default should do +glgui) and installing with "-glgui" and see if both build and execute property. If they do, then somehow this ticket was addressed. If this issue persists, I'd encourage you to try the "fltk-devel" port instead of "fltk" and see if that fixes the issue.

comment:3 Changed 6 years ago by michaelld (Michael Dickens)

This issue is now showing up in some the buildbots. I don't see it on my 10.8 install for some reason. I'm trying with just "fltk" to see if that makes any difference. If you want to provide more feedback, you could do the selfupdate above, then:

sudo port clean octave
sudo port install octave use_parallel_build=no

this will take a lot longer since it's not a parallel build; but, when the error happens the build will fail and it's trivial to track down where the error actually occurred in the build.

comment:4 Changed 6 years ago by zanderpower@…

octave @3.8.2_4+accelerate+gcc47+gui+metis-atlas-x11 after first installing gl2ps and fltk-devel has been working for me--on a PPC PowerBook with Leopard. Octave finds gl2ps automatically. I did add the line

--with-framework-carbon

to Octave's portfile first (and built without the x11 variant). However, I don't know if this will work on OS X 10.8.5.

comment:5 Changed 6 years ago by zanderpower@…

I don't even know if Mountain Lion has a carbon framework...

comment:6 Changed 6 years ago by michaelld (Michael Dickens)

Octave auto-detects for Carbon unless we tell it not to (--without-framework-carbon), which we don't; we let it decide which way to go. I don't know if Carbon is provided in 10.9+; it is in 10.8-. But, that does not seem to be the issue: I run 10.8 and my install works with respect to this issue, but another 10.8 install does not work. I don't have enough data to figure out what's going on; hence the request for build files using "use_parallel_build=no" ...

Thus, as a follow-up, can folks with this issue try the following:

sudo port clean octave
sudo port selfupdate
sudo port -f uninstall `port installed gl2ps | sed -e 1d -e "s@(active)@@"`
sudo port -f uninstall `port installed "fltk*" | sed -e 1d -e "s@(active)@@"`
sudo port -s install gl2ps
sudo port -s install fltk[-devel]
sudo port -s install octave use_parallel_build=no

where the [-devel] is optional, and see if that works? If not, then attach the "use_parallel_build=no" debug log for octave to this ticket.

Changed 6 years ago by rspinney20@…

Attachment: main2.log.tar.gz added

comment:7 Changed 6 years ago by rspinney20@…

I'm afraid none of that worked (I tried everything above)

Choosing -glgui did allow octave to build, but without the fltk graphics toolkit so it's not a solution.

The log of the fail with the parallel build set to off is attached as main2.log.tar.gz

Thanks,

R.

comment:8 Changed 6 years ago by michaelld (Michael Dickens)

OK; interesting. What do the following command return:

lipo -detailed_info /opt/local/lib/libgl2ps*.dylib
nm -a /opt/local/lib/libgl2ps*.dylib | grep Disable

comment:9 Changed 6 years ago by rspinney20@…

I get:

input file /opt/local/lib/libgl2ps.1.3.8.dylib is not a fat file

input file /opt/local/lib/libgl2ps.1.dylib is not a fat file

input file /opt/local/lib/libgl2ps.dylib is not a fat file

Non-fat file: /opt/local/lib/libgl2ps.1.3.8.dylib is architecture: x86_64

Non-fat file: /opt/local/lib/libgl2ps.1.dylib is architecture: x86_64

Non-fat file: /opt/local/lib/libgl2ps.dylib is architecture: x86_64

0000000000005524 T _gl2psDisable

0000000000005524 T _gl2psDisable

0000000000005524 T _gl2psDisable

Also, as a result of the update above, I find myself in a position where I now cannot build octave with FLTK at all because gl2ps is now being forcibly installed as a dependency when I install octave normally, which causes it to fail. Whereas before I could install octave whilst linking to fltk, but without gl2ps being installed allowing me, at least, to plot with it and, as a last gasp option, perform a screen grab or similar.

In other words if I specify

sudo port install octave (ie with +glgui), it installs gl2ps and fltk if not already installed causing it to fail for the above reasons

and if i specify

sudo port install octave -glgui, it doesn't link with fltk at all so I lose that functionality.

Last edited 6 years ago by rspinney20@… (previous) (diff)

comment:10 Changed 6 years ago by michaelld (Michael Dickens)

Interesting. I'd prefer to fix this issue rather than add another variant for +gl2ps. So, please bear with me here & we'll figure it out. I don't see this issue on either my 10.8 or 10.10 installs. Not that it doesn't exist, but if I can recreate the issue then its easier for me to debug.

If you go back to the failed build:

sudo port clean octave
sudo port build octave

then do:

otool -L `port work octave`/octave-3.8.2/libinterp/.libs/liboctinterp.2.dylib | grep gl2ps

what does this command return?

comment:11 Changed 6 years ago by michaelld (Michael Dickens)

This is a duplicate of #44704. So, I'm going to close this ticket and add you to that ticket. I will re-post the above request on that ticket, for others to see as well.

comment:12 Changed 6 years ago by michaelld (Michael Dickens)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.