Opened 6 years ago

Closed 6 years ago

#46938 closed defect (worksforme)

Miriad installed using MacPorts not working

Reported by: gemma.anderson@… Owned by: pkgw (Peter Williams)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: miriad

Description (last modified by mf2k (Frank Schima))

Hi,

I have just tried to install Miriad on Mavericks using MacPorts. No errors were output during the installation. However, when I start Miriad I get the following error:

MIRIAD VERSION:
cat: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_miriad/miriad/work/miriad-4.3.8/VERSION: No such file or directory

I then try to run something like "uvplt" and it just Aborts.

I have tried installing the Mavericks version of MacPorts but that has not fixed the problem (this was not a migration so it might not have been done properly)

Thanks very much, Gemma Anderson

Change History (13)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to peter@…
Port: miriad added

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers miriad), if any.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 6 years ago by pkgw (Peter Williams)

What is the specific error message that happens when you run something like uvplt? Just "Aborted" or anything more?

comment:4 in reply to:  3 Changed 6 years ago by gemma.anderson@…

Replying to peter@…:

What is the specific error message that happens when you run something like uvplt? Just "Aborted" or anything more?

When I type 'go' for any task it just prints 'Abort' and exits Miriad.

I think my Miriad installation worked before I upgraded to Mavericks.

comment:5 Changed 6 years ago by pkgw (Peter Williams)

Hmmm, OK. Do you get the same results if you run a command such as uvplt directly from the terminal, rather than inside the MIRIAD shell?

comment:6 in reply to:  5 Changed 6 years ago by gemma.anderson@…

Replying to peter@…:

Hmmm, OK. Do you get the same results if you run a command such as uvplt directly from the terminal, rather than inside the MIRIAD shell?

No. If I run uvplt directly from the terminal it all works properly.

comment:7 Changed 6 years ago by pkgw (Peter Williams)

OK, I'll investigate. As a heads-up, I and most users of the MIRIAD MacPort don't use the MIRIAD shell, so broadly speaking it's probably not going to be the most reliable part of the system.

comment:8 Changed 6 years ago by pkgw (Peter Williams)

Unfortunately I can't reproduce this on my pre-Mavericks machine. I'll have to find a coworker with a newer computer that I can borrow to see if that makes a difference.

It sounds like you're working off of a fresh install, but just in case, it might possibly help to completely remove miriad, make sure that all other MacPorts packages are updated, then reinstall.

comment:9 in reply to:  8 Changed 6 years ago by gemma.anderson@…

Replying to peter@…:

Unfortunately I can't reproduce this on my pre-Mavericks machine. I'll have to find a coworker with a newer computer that I can borrow to see if that makes a difference.

It sounds like you're working off of a fresh install, but just in case, it might possibly help to completely remove miriad, make sure that all other MacPorts packages are updated, then reinstall.

Could you please tell me the exact commands I need to use to uninstall miriad?

I have actually been using Miriad on the command line and it has been working fine.

comment:10 Changed 6 years ago by pkgw (Peter Williams)

Running

sudo port uninstall miriad 

should do the trick. If there's a complaint about multiple versions, you run something like

sudo port uninstall miriad@4.3.8.20141105 

After you've done that, then

sudo port selfupdate
sudo port upgrade outdated

would be good for verifying that your MacPorts installation is fully up-to-date.

Last edited 6 years ago by pkgw (Peter Williams) (previous) (diff)

comment:11 Changed 6 years ago by pkgw (Peter Williams)

A colleague reports that he can't reproduce the problem with a Mavericks machine, so I think this problem is specific to your installation. As such, I'm going to mark this bug report as closed, but I'm happy to help you work through fixing the shell over email (pwilliams@…).

comment:12 Changed 6 years ago by pkgw (Peter Williams)

Hmmm, actually, I seem unable to close the ticket myself for some reason so I guess it'll stay listed as "open" for the time being. MacPorts folks?

comment:13 Changed 6 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.