Opened 6 years ago

Closed 5 years ago

#46947 closed update (fixed)

sox: please update to @14.4.2

Reported by: mopihopi Owned by: janstary (Jan Starý)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: sox

Description

Please update sox to @14.4.2.

Note that sox 14.4.2 can now read Ogg Opus files, using the opusfile library, so the dependencies will probably need to be updated.

Attachments (2)

Portfile (1.8 KB) - added by janstary (Jan Starý) 6 years ago.
upgrade to 14.4.2
Portfile.diff (2.8 KB) - added by janstary (Jan Starý) 5 years ago.
a cleaner Portfile diff

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by janstary (Jan Starý)

I am working on this. The problem is opusfile does not compile on my 10.5.8, as it doesn't have AI_NUMERICSERV defined.

One option is to create an updated port of SoX 14.4.2 decidedly --without-opus now, and improive it to actually use opus later.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Cc: hans@… removed
Owner: changed from macports-tickets@… to hans@…

comment:3 Changed 6 years ago by janstary (Jan Starý)

Now that I can install opusfile, here is an upgrade to SoX 14.4.2

  • update licence to GPL3, because opencore-amr is Apache
  • trim needless verbiage from the long description
  • ./configure --with-opus, add libopus and opusfile as dependencies
  • reorder dependencies alphabetically while there
  • drop --without-ffmpeg as it has been kicked out

Tested on 10.5.8 on an old MacBook, can other users please test elsewhere?

Jan

Changed 6 years ago by janstary (Jan Starý)

Attachment: Portfile added

upgrade to 14.4.2

comment:4 Changed 6 years ago by janstary (Jan Starý)

Portfile replaced with a slightly neater one:

  • split the confgure.args to audio formats and output drivers
  • reorder the ./cofigure args to follow ./configure --help
  • add --with-distro=macosx to make SoX's messages slightly happier
  • gomp has been renamed to openmp

comment:5 Changed 6 years ago by mopihopi

Thanks! I tried the Portfile on OS X 10.9.5 and it seems to be working. For some reason sox --version is just showing sox: SoX v with no version number, but apparently that is an existing issue as the previous version seems to do the same thing.

comment:6 Changed 6 years ago by mopihopi

BTW installing the new sox required the mlt port to be rebuilt, so mlt may need a revbump:

--->  Activating sox @14.4.2_0
--->  Cleaning sox
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  Found 1 broken file(s), matching files to ports    
--->  Found 1 broken port(s), determining rebuild order
--->  Rebuilding in order
     mlt @0.9.2 

comment:7 Changed 6 years ago by janstary (Jan Starý)

On my system the version is reported fine:

$ sox --version
sox:      SoX v14.4.2

If you run just 'sox' and save the whole output, does it say 'sox: SoX v14.4.2' at the top?

comment:8 in reply to:  6 Changed 6 years ago by janstary (Jan Starý)

Replying to mopihopi@…:

BTW installing the new sox required the mlt port to be rebuilt, so mlt may need a revbump:

Right, I forgot about the dependents; sorry. These are gimp-gap-devel, mlt, sounddecompress, tovid.

I don't personally use any of those. I can give them all a spin, but could serious users please check that this upgrade of SoX does not break them?

Thanks

comment:9 Changed 6 years ago by mopihopi

Just sox by itself has the same issue with the missing version number:

$ sox
sox:      SoX v

sox FAIL sox: Not enough input filenames specified

Usage summary: [gopts] [[fopts] infile]... [fopts] outfile [effect [effopt]]...

SPECIAL FILENAMES (infile, outfile):
...

I'm using OS X 10.9.5 with Xcode 6.1.1 and the default compiler: Apple LLVM version 6.0 (clang-600.0.56)

comment:10 Changed 6 years ago by mopihopi

The missing version number also occurs with the upstream version. Filed upstream: http://sourceforge.net/p/sox/patches/104/

comment:11 Changed 6 years ago by mf2k (Frank Schima)

Per the guidelines, please instead attach a unified diff of the Portfile so we can easily see what changes you are proposing.

comment:12 Changed 6 years ago by janstary (Jan Starý)

Sorry; attaching a diff to the curent Portfile.

comment:13 Changed 6 years ago by mf2k (Frank Schima)

You have whitespace changes in this patch which makes it hard to evaluate the changes you are proposing. We prefer a separate patch for that. Doing this will greatly increase your odds of getting the patch committed.

Changed 5 years ago by janstary (Jan Starý)

Attachment: Portfile.diff added

a cleaner Portfile diff

comment:14 in reply to:  13 Changed 5 years ago by janstary (Jan Starý)

Replying to mf2k@…:

You have whitespace changes in this patch which makes it hard to evaluate the changes you are proposing. We prefer a separate patch for that. Doing this will greatly increase your odds of getting the patch committed.

A cleaner diff attached.

comment:15 Changed 5 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

Commited in r142250 (only whitespace changes) and r142255. In future, please submit whitespace only (like indentation, alignment, etc.) separately from functional changes.

Note: See TracTickets for help on using tickets.