Opened 5 years ago

Closed 5 years ago

#47159 closed update (fixed)

intltool @0.50.2_4: update to 0.51.0

Reported by: Schamschula (Marius Schamschula) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: larryv (Lawrence Velázquez)
Port: intltool

Description

intltool has been updated to version 0.51.0.

Attachments (1)

Portfile-intltool.diff (883 bytes) - added by Schamschula (Marius Schamschula) 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-intltool.diff added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to larryv@…
Status: newassigned
Summary: intltool @0.50.2: update to 0.51.0intltool @0.50.2_0: update to 0.51.0
Version: 2.3.3

Thanks.

comment:2 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: assignedclosed

comment:3 Changed 5 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: closedreopened

comment:4 Changed 5 years ago by dbevans (David B. Evans)

Larry, this version of intltool has changes that break the builds of many ports that depend on it. In particular, I suspect that all ports that currently autoreconf to update intltool.m4 to our patched version will break. This includes many GNOME ports. The change (upstream bzr 742) effects both intltool.m4 and po/Makefile.in.in which both need to be updated before running configure for things to work again. In addition, in many cases, the change results in a change in the installed locale directory path.

The fix is to do a full reconfiguration of each of the ports in question using intltoolize which generally is omitted when using autoreconf. Typically this means using the upstream autogen.sh or similar to rebuild the configuration. I've confirmed that this works with several test cases.

Since this effects so many GNOME ports and GNOME 3.16rc is due out tomorrow with the final GNOME 3.16 following a week later, I wonder if you would revert this update for now so that the existing GNOME 3.14 ports will build again as is and I'll work the necessary changes into the 3.16 versions and reinstate the 0.51 version as part of the GNOME 3.16 rollout in a few weeks time.

Thanks

Last edited 5 years ago by dbevans (David B. Evans) (previous) (diff)

comment:5 Changed 5 years ago by dbevans (David B. Evans)

To quantify the problem, I count 119 ports that autoreconf to update intltool.m4 and need to be checked and probably fixed.

An example of a port that now breaks is yelp. The problem becomes apparent in the destroot phase:

--->  Staging yelp into destroot
Warning: violation by /opt/local/@DATADIRNAME@
Warning: yelp violates the layout of the ports-filesystems!
Warning: Please fix or indicate this misbehavior (if it is intended), it will be an error in future releases!

The old po/Makefile.in.in expects intltool.m4 to set DATADIRNAME to the path for the locale directory but the 0.51 intltool.m4 doesn't do that any more. The new po/Makefile.in.in dispenses with DATADIRNAME and uses the standard @localedir@ substitution instead.

An example of a port that DOES NOT break is empathy which reconfigures using autogen.sh to update intltool.m4 (and po/Makefile.in.in too!).

Last edited 5 years ago by dbevans (David B. Evans) (previous) (diff)

comment:6 in reply to:  4 ; Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added
Owner: changed from larryv@… to devans@…
Status: reopenednew
Summary: intltool @0.50.2_0: update to 0.51.0intltool @0.50.2_4: update to 0.51.0

Gah, sorry. I’ve rolled it back in r134061. If you don’t mind, I’ll also reassign this ticket to you, since you seem to actually know what you’re doing with intltool.

comment:7 in reply to:  6 Changed 5 years ago by dbevans (David B. Evans)

Status: newassigned

Replying to larryv@…:

Gah, sorry. I’ve rolled it back in r134061. If you don’t mind, I’ll also reassign this ticket to you, since you seem to actually know what you’re doing with intltool.

Thanks, that should stop the breakage for now. Sure, I'll take the lead on this one, looks like you have your hands full with bison3.

comment:8 Changed 5 years ago by dbevans (David B. Evans)

Assumed maintainership openmaintainer, warning comments in r134063.

comment:9 Changed 5 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

Updated once again to version 0.51.0 in r136073, after updating the majority of intltool dependents for 0.51.0 compatibility. Any remaining ports will be fixed as required/time permits. If you see any problems, please file a port specific ticket.

Note: See TracTickets for help on using tickets.