Opened 6 years ago

Closed 6 years ago

#47334 closed defect (fixed)

clang-3.7: libcompiler_rt.a: No such file or directory

Reported by: davidfavor (David Favor) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: larryv (Lawrence Velázquez)
Port: clang-3.7

Description (last modified by ryandesign (Ryan Schmidt))

I'm building clang on several Mavericks systems. They are all the same XCode version with all updates installed.

All systems show the same SDK...

xcrun --sdk macosx --show-sdk-path
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk

I've attached the log from the failing system.

Attachments (1)

clang-3.7-main.log (8.0 MB) - added by davidfavor (David Favor) 6 years ago.

Change History (7)

Changed 6 years ago by davidfavor (David Favor)

Attachment: clang-3.7-main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to jeremyhu@…
Port: clang-3.7 added
Summary: Building clang-3.7 on some systems failsclang-3.7: libcompiler_rt.a: No such file or directory

This looks a lot like #47241 except there it was libcompiler_rt.dylib that could not be found and here it is libcompiler_rt.a.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: larryv@… added

comment:3 Changed 6 years ago by davidfavor (David Favor)

Does look similar to the other ticket.

I thought something might be wrong with XCode on the failing machine, so I went through + installed all updates from XCode -> Preferences + same problem remains.

Several Ubuntu tickets mention removing $PREFIX from environment resolved similar problems, so I removed $CDPATH + $PREFIX + same problem remains.

comment:4 Changed 6 years ago by davidfavor (David Favor)

Well. I thought I'd be smart + reinstall on the machine that was working + clang-3.7 fails to reinstall, on machine where it use to work.

I just checked + clang-3.6 installs fine on all machines.

comment:5 Changed 6 years ago by davidfavor (David Favor)

This bug fixed as of yesterday's clang/llvm update.

comment:6 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.