Opened 6 years ago

Closed 5 years ago

Last modified 2 months ago

#47336 closed defect (fixed)

py-tables: Port cannot find #include <mpi.h>

Reported by: citibob@… Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: petrrr, gnurser (George Nurser)
Port: py-tables

Description (last modified by ryandesign (Ryan Schmidt))

The following "hack" to the Portfile got it to work for me (for the command port install py27-tables +gcc49)

    compiler.cpath-append ${prefix}/include/openmpi-gcc49 

I don't know how to do this right, so it would work for any supported compiler.

Change History (9)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: py27-tables removed
Owner: changed from macports-tickets@… to mmoll@…
Summary: Port cannot find #include <mpi.h>py-tables: Port cannot find #include <mpi.h>

comment:2 Changed 6 years ago by seanfarley (Sean Farley)

I don't have the time to fully look into this now but the solution would be to use the mpi portgroup similar to how py-mpi4py does.

comment:3 Changed 6 years ago by mamoll (Mark Moll)

I cannot reproduce this. I installed hdf5+openmpi and then installed py34-tables without errors. Perhaps you had hdf5 installed without the +openmpi variant?

comment:4 Changed 5 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:5 Changed 5 years ago by petrrr

Cc: gnurser@… added

Has duplicate #48789, adding reporter of the ticket.

comment:6 in reply to:  5 Changed 5 years ago by gnurser (George Nurser)

Replying to petr@…:

Has duplicate #48789, adding reporter of the ticket.

This used to work for me until very recently. Same error if I try to upgrade py34-tables.

My hdf5 is hdf5 @1.8.15-patch1_0+cxx+gcc49+openmpi

comment:7 Changed 5 years ago by seanfarley (Sean Farley)

Resolution: invalid
Status: newclosed

The fix is to build py-tables with the same mpi variant as hdf5. In your case, sudo port install py27-tables +gcc49 +openmpi.

comment:8 in reply to:  7 Changed 5 years ago by gnurser (George Nurser)

Replying to sean@…:

The fix is to build py-tables with the same mpi variant as hdf5. In your case, sudo port install py27-tables +gcc49 +openmpi.

Tnanks; this now works fine.

comment:9 Changed 2 months ago by dstrubbe (David Strubbe)

Resolution: invalidfixed

In 7f3260c4efe0b140522c0a81bf0dee15deb27e96/macports-ports (master):

py-tables: Enforce same MPI variant (if any) as HDF5.

Prevents possible build failures.
Fixes: #47336 (already closed, but this actually settles it)

Note: See TracTickets for help on using tickets.