Opened 4 years ago

Closed 4 years ago

#47360 closed enhancement (fixed)

watchman @3.0.0_0: missing pcre dependency

Reported by: wez+macports@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: watchman

Description

Watchman can optionally be built with pcre support.

Please add the appropriate dependency and the --with-pcre configure argument so that it gets picked up and so that the macport distribution matches the capabilities of the homebrew distribution for watchman.

PS: in the upcoming week we're planning on releasing watchman 3.1.

Change History (4)

comment:1 Changed 4 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to sean@…
Summary: watchman 3.0.0 missing pcre dependencywatchman @3.0.0_0: missing pcre dependency

comment:2 Changed 4 years ago by seanfarley (Sean Farley)

Ok, maybe we can just wait for the update to 3.1?

comment:3 Changed 4 years ago by wez+macports@…

I just now tagged v3.1 (was waiting on code review for a couple of diffs). I'm fine with pcre going in with a 3.1 update. Thanks!

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

watchman was updated to 3.1 in r134783 and the pcre dependency was added.

Note: See TracTickets for help on using tickets.