Opened 5 years ago

Closed 4 years ago

#47380 closed update (fixed)

p11-kit @0.22.1_0: update to 0.23.1

Reported by: Schamschula (Marius Schamschula) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: p11-kit

Description

p11-kit has been updated to version 0.23.1:

* Use new PKCS#11 URI draft fields for URIs [#86474 #87582]
* Add pem-directory-hash extract format
* Build fixes

Attachments (1)

Portfile-p11-kit.diff (968 bytes) - added by Schamschula (Marius Schamschula) 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-p11-kit.diff added

comment:1 Changed 5 years ago by dbevans (David B. Evans)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…
Status: newassigned
Version: 2.3.3

comment:2 Changed 5 years ago by dbevans (David B. Evans)

Resolution: wontfix
Status: assignedclosed

This is an unstable devel release. Will update at next stable.

comment:3 Changed 5 years ago by Schamschula (Marius Schamschula)

That's OK. The only reason I built p11-kit 0.23.1 is that it is a prerequisite for creating gnutls-devel (3.4.0).

For the moment I've abandoned gnutls-devel, as we have a serious issue with nettle 2.7.x vs. 3.1. I'll revisit this when 3.4.0 becomes the main stable branch.

Version 0, edited 5 years ago by Schamschula (Marius Schamschula) (next)

comment:4 Changed 4 years ago by Schamschula (Marius Schamschula)

I'm not sure when p11-kit (currently at 0.23.2) will have the next stable release, i.e. 0.24.

However, gnutls 3.4.x has been declared the stable branch since version 3.4.7 (November 2015). I would like to update gnutls to the current stable branch (as my FreeBSD machine is updating from 3.4.10 to 3.4.11).

Last edited 4 years ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:5 Changed 4 years ago by dbevans (David B. Evans)

What version of p11-kit does gnutls 3.4.11 require?

comment:6 Changed 4 years ago by Schamschula (Marius Schamschula)

This is what I get when running configure:

configure: error: 
***
*** p11-kit >= 0.23.1 was not found. To disable PKCS #11 support
*** use --without-p11-kit, otherwise you may get p11-kit from
*** http://p11-glue.freedesktop.org/p11-kit.html
***

comment:7 Changed 4 years ago by dbevans (David B. Evans)

Updated p11-kit to version 0.23.2 in r147741 to support upgrade of gnutls to latest stable version. ABI compatible with previous version.

comment:8 Changed 4 years ago by dbevans (David B. Evans)

Resolution: wontfix
Status: closedreopened

comment:9 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.