Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#47389 closed defect (fixed)

FreeRDP fails to configure with cmake >= 3.1

Reported by: frederic.ramage@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: FreeRDP

Description

Hi,

when trying to install freeRDP, with all dependencies, it's always failed with the same error while configuring.

I've attached the logs file, done with the command: sudo port clean freerdp && sudo port install FreeRDP build.jobs=1

At this step, I cannot solve this problem by myself.

It would be fine it someone can help me. I need this library to compile Guacamole on OSX.

Best Regards, Frédéric

Attachments (1)

main.log (115.1 KB) - added by frederic.ramage@… 4 years ago.
the debug log file

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by frederic.ramage@…

Attachment: main.log added

the debug log file

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Keywords: freeRDP removed
Port: FreeRDP added
Priority: HighNormal

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

I agree, FreeRDP fails to configure today. However, it successfully configured when I installed it on September 25, 2014, so something has changed since then—and it's not the FreeRDP port itself. The cmake port and the cmake portgroup have both had updates since then however.

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

I found the upstream bug report. They say FreeRDP does not build with cmake 3 or newer. (I think they meant 3.1 or newer, since MacPorts had cmake 3.0.2 when I successfully build FreeRDP in September.) MacPorts has cmake 3.2.1 today so FreeRDP cannot be built until the developers of FreeRDP fix this problem. If you like, you can work around the problem by downgrading cmake to an older version.

comment:4 Changed 4 years ago by frederic.ramage@…

Hi,

great, you found it. thanks a lot. I'll try to downgrade frreRDP port.

comment:5 Changed 4 years ago by ryandesign (Ryan Schmidt)

The FreeRDP port doesn't need to be downgraded; it hasn't changed. The cmake port has changed, and needs to be downgraded to allow FreeRDP to build. I've just confirmed that backing the cmake port down to r132984 when it was at version 3.0.2 allows FreeRDP to build.

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Summary: freeRDP failed to configure on YOSEMITEFreeRDP fails to configure with cmake >= 3.1

comment:7 Changed 4 years ago by frederic.ramage@…

Hi,

i'm currently stuck. I've downloaded cmake 3.0.2 (via the link you've provided). I've uninstalled cmake (port uninstall cmake)

I've uncompressed the download Portfile. Put in the /private/tmp directory, but when I tried to install it (port install) in the directory of the uncompressed Portfile, I always have the same error: Error: Unable to execute port: Could not open file: /private/tmp/cmake/Portfile

After some Googling, I'm still stuck.

If you have some time to help me, It would be cool.

Thanks again, Best Regards

comment:8 Changed 4 years ago by frederic.ramage@…

Leave it alone, I finaly get it work.

but when I pass on compiling freeRDP, it always reinstall by itself make 3 2 1.

Last edited 4 years ago by frederic.ramage@… (previous) (diff)

comment:9 Changed 4 years ago by diwu1989@…

I'm hitting this problem too, really need freerdp to work again.

comment:10 Changed 4 years ago by neverpanic (Clemens Lang)

This isn't going to get fixed by itself, and the port doesn't have a maintainer. Please provide a patch, step up as maintainer, talk to upstream, provide a patch to upstream, file a bug upstream or all of the above to get this fixed.

I've briefly looked into it, but the FreeRDP "release" cycle is way too convoluted for me to waste my free time on it if I don't use it.

comment:11 Changed 4 years ago by diwu1989@…

I filed ticket on FreeRDP on github https://github.com/FreeRDP/FreeRDP/issues/2545 and it seems the problem is fixed in the stable-1.1 branch https://github.com/FreeRDP/FreeRDP/commits/stable-1.1

I'm not familiar with the portfile system, would you be able to update the portfile to use the stable 1.1 sourcecode instead of the beta?

comment:12 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

As suggested fixed by updating to latest github stable-1.1 branch in r135595.

comment:13 in reply to:  12 Changed 4 years ago by diwu1989@…

Replying to devans@…:

As suggested fixed by updating to latest github stable-1.1 branch in r135595.

Thanks devans! Really really appreciate this!

Note: See TracTickets for help on using tickets.