Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#47436 closed defect (fixed)

libvpx @1.3.0: yasm: FATAL: unrecognized object format `machox32'

Reported by: nistix@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: lucorsica@…
Port: libvpx

Description

Install 'libvpx' failed:

olegs-mac-mini:build nistix$ sudo port install libvpx
--->  Computing dependencies for libvpx
--->  Fetching archive for libvpx
--->  Attempting to fetch libvpx-1.3.0_1+universal.darwin_14.i386-x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/libvpx
--->  Attempting to fetch libvpx-1.3.0_1+universal.darwin_14.i386-x86_64.tbz2 from http://lil.fr.packages.macports.org/libvpx
--->  Attempting to fetch libvpx-1.3.0_1+universal.darwin_14.i386-x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/libvpx
--->  Fetching distfiles for libvpx
--->  Verifying checksums for libvpx
--->  Extracting libvpx
--->  Applying patches to libvpx
--->  Configuring libvpx
--->  Building libvpx
Error: org.macports.build for port libvpx returned: command execution failed
Please see the log file for port libvpx for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port libvpx failed

Cat of /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/main.log:

...
:info:build yasm -f machox32 -I./ -I"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/work/libvpx-v1.3.0-i386"/ -o vpx_ports/emms.asm.o vpx_ports/emms.asm
:info:build yasm -f machox32 -I./ -I"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/work/libvpx-v1.3.0-i386"/ -o vpx_ports/x86_abi_support.asm.o vpx_ports/x86_abi_support.asm
:info:build yasm: FATAL: unrecognized object format `machox32'
:info:build make[1]: *** [vpx_ports/emms.asm.o] Error 1
:info:build make[1]: *** Waiting for unfinished jobs....
:info:build yasm: FATAL: unrecognized object format `machox32'
:info:build make[1]: *** [vpx_ports/x86_abi_support.asm.o] Error 1
:info:build make: *** [.DEFAULT] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/work/libvpx-v1.3.0-i386'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_libvpx/libvpx/work/libvpx-v1.3.0-i386" && /usr/bin/make -j4 -w verbose=1 CFLAGS_S=-fno-integrated-as 
:info:build Exit code: 2
:error:build org.macports.build for port libvpx returned: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
    while executing
"proc-org.macports.build-build-0 org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for libvpx: org.macports.activate org.macports.build org.macports.destroot org.macports.install

Change History (9)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: libvpx yasm removed
Owner: changed from macports-tickets@… to devans@…
Summary: libvpx @1.3.0 Error: command execution failedlibvpx @1.3.0: yasm: FATAL: unrecognized object format `machox32'

comment:2 Changed 6 years ago by dbevans (David B. Evans)

Status: newassigned

comment:3 Changed 6 years ago by dbevans (David B. Evans)

Cc: lucorsica@… added
Version: 2.3.3

This appears to be a problem with the +universal build. Has duplicate #47484 which includes a complete build log. CCing that reporter as well.

Can you both please verify which version of Mac OS X you are using and the version of Xcode installed?

Last edited 6 years ago by dbevans (David B. Evans) (previous) (diff)

comment:4 Changed 6 years ago by lucorsica@…

Hello, I'm using:

Yosemite 10.10.3 and Xcode 6.3 (6D570)

Last edited 6 years ago by lucorsica@… (previous) (diff)

comment:5 Changed 6 years ago by dbevans (David B. Evans)

Thanks.

My testing confirms that the issue is unique to the +universal build when using Xcode 6.3: earlier versions build correctly.

The problem stems from a cpp configuration test during the i386 build phase that is interpreted differently by 6.3, eventually resulting in yasm being invoked erroneously as

yasm -f machox32

rather than

yasm -f macho32

Fix committed in r135165. Please verify that this fixes your issue.

comment:6 in reply to:  5 Changed 6 years ago by lucorsica@…

Replying to devans@…:

Thanks.

My testing confirms that the issue is unique to the +universal build when using Xcode 6.3: earlier versions build correctly.

The problem stems from a cpp configuration test during the i386 build phase that is interpreted differently by 6.3, eventually resulting in yasm being invoked erroneously as

yasm -f machox32

rather than

yasm -f macho32

Fix committed in r135165. Please verify that this fixes your issue.

Hmm excuse me but what am I supposed to do exactly? What should I do with the file from r135165?

comment:7 Changed 6 years ago by dbevans (David B. Evans)

Sorry. Just update your ports to get the new fix and try a clean build.

sudo port selfupdate
sudo port clean libvpx
sudo port install libvpx +universal

comment:8 in reply to:  7 Changed 6 years ago by lucorsica@…

Replying to devans@…:

Sorry. Just update your ports to get the new fix and try a clean build.

sudo port selfupdate
sudo port clean libvpx
sudo port install libvpx +universal

Thanks! But I tried again and got that error this time:

Error: org.macports.archivefetch for port ffmpeg returned: libsdl must be installed with +x11.

comment:9 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

This implies that libvpx now builds correctly for you so this ticket has been satisfied.

The error you now report just means what it says. Port ffmpeg requires libsdl +x11. You apparently have a version installed without the +x11 variant. To fix this (assuming your continuing to build +universal)

sudo port install libsdl +x11 +universal
sudo port clean ffmpeg
sudo port install ffmpeg +universal

If you have further problems along this line, try the macports-users mailing list for technical support.

Last edited 6 years ago by dbevans (David B. Evans) (previous) (diff)
Note: See TracTickets for help on using tickets.