Opened 6 years ago

Closed 6 years ago

#47464 closed defect (duplicate)

mapnik +gdal +postgis +sqlite @ 2.2.0 fails to build

Reported by: jczaplew@… Owned by: bpanulla (Brian Panulla)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: stromnov (Andrew Stromnov)
Port: mapnik

Description (last modified by mf2k (Frank Schima))

mapnik is failing to build on the "Building mapnik" step when installing with port install mapnik +gdal +postgis +sqlite

This is the end of the error in /opt/local/var/macports/logs/_opt_local_var_macports_sources_rysnc.macports.org_release_tarballs_ports_gis_mapnik/mapnik/main.log

:info:build 2 warnings and 5 errors generated.
:info:build scons: *** [bindings/python/mapnik_geometry.os] Error 1
:info:build scons: building terminated because of errors.
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_mapnik/mapnik/work/mapnik-2.2.0" && /opt/local/bin/python2.7 scons/scons.py -j8 
:info:build Exit code: 2
:error:build org.macports.build for port mapnik returned: command execution failed
:debug:build Error code: CHILDSTATUS 6558 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"

I attempted to clean with no success. Any and all help would be appreciated! Thanks!

Attachments (1)

main.log (214.0 KB) - added by jczaplew@… 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: stromnov@… added
Owner: changed from macports-tickets@… to macports@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers mapnik), if any.

Your output does not show the actual error. Please attach the complete main.log file.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 6 years ago by mf2k (Frank Schima)

Keywords: gis removed

Changed 6 years ago by jczaplew@…

Attachment: main.log added

comment:4 Changed 6 years ago by jczaplew@…

Sorry about that - first time filing an issue. I added the error log. Thanks for your help!

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #45944.

Note: See TracTickets for help on using tickets.