Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#47520 closed defect (duplicate)

webkit-gtk3 @2.4.8_1 build failure

Reported by: life.130815@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: anddam (Andrea D'Amore), dbevans (David B. Evans)
Port: webkit-gtk3

Description (last modified by anddam (Andrea D'Amore))

:info:build Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:121:5: error: reference to 'GMutexLocker' is ambiguous
:info:build     GMutexLocker lock(priv->bufferMutex);
:info:build     ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:276:14: note: candidate found by name lookup is 'GMutexLocker'
:info:build typedef void GMutexLocker;
:info:build              ^
:info:build ./Source/WTF/wtf/gobject/GMutexLocker.h:32:7: note: candidate found by name lookup is 'WebCore::GMutexLocker'
:info:build class GMutexLocker {
:info:build       ^
:info:build Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:143:5: error: reference to 'GMutexLocker' is ambiguous
:info:build     GMutexLocker lock(priv->bufferMutex);
:info:build     ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:276:14: note: candidate found by name lookup is 'GMutexLocker'
:info:build typedef void GMutexLocker;
:info:build              ^
:info:build ./Source/WTF/wtf/gobject/GMutexLocker.h:32:7: note: candidate found by name lookup is 'WebCore::GMutexLocker'
:info:build class GMutexLocker {
:info:build       ^
:info:build Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:282:5: error: reference to 'GMutexLocker' is ambiguous
:info:build     GMutexLocker lock(priv->bufferMutex);
:info:build     ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:276:14: note: candidate found by name lookup is 'GMutexLocker'
:info:build typedef void GMutexLocker;
:info:build              ^
:info:build ./Source/WTF/wtf/gobject/GMutexLocker.h:32:7: note: candidate found by name lookup is 'WebCore::GMutexLocker'
:info:build class GMutexLocker {
:info:build       ^
:info:build Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:308:9: error: reference to 'GMutexLocker' is ambiguous
:info:build         GMutexLocker lock(priv->bufferMutex);
:info:build         ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:276:14: note: candidate found by name lookup is 'GMutexLocker'
:info:build typedef void GMutexLocker;
:info:build              ^
:info:build ./Source/WTF/wtf/gobject/GMutexLocker.h:32:7: note: candidate found by name lookup is 'WebCore::GMutexLocker'
:info:build class GMutexLocker {
:info:build       ^
:info:build Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:333:5: error: reference to 'GMutexLocker' is ambiguous
:info:build     GMutexLocker lock(priv->bufferMutex);
:info:build     ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:276:14: note: candidate found by name lookup is 'GMutexLocker'
:info:build typedef void GMutexLocker;
:info:build              ^
:info:build ./Source/WTF/wtf/gobject/GMutexLocker.h:32:7: note: candidate found by name lookup is 'WebCore::GMutexLocker'
:info:build class GMutexLocker {
:info:build       ^
:info:build 7 warnings and 5 errors generated.
:info:build GNUmakefile:51688: recipe for target 'Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-VideoSinkGStreamer.lo' failed
:info:build gmake[1]: *** [Source/WebCore/platform/graphics/gstreamer/libPlatformGtk_la-VideoSinkGStreamer.lo] Error 1
:info:build gmake[1]: *** Waiting for unfinished jobs....
:info:build mv -f Source/WebCore/platform/graphics/gtk/.deps/libPlatformGtk_la-IntRectGtk.Tpo Source/WebCore/platform/graphics/gtk/.deps/libPlatformGtk_la-IntRectGtk.Plo
:info:build mv -f Source/WebCore/platform/graphics/gtk/.deps/libPlatformGtk_la-IntPointGtk.Tpo Source/WebCore/platform/graphics/gtk/.deps/libPlatformGtk_la-IntPointGtk.Plo
:info:build mv -f Source/WebCore/platform/graphics/opentype/.deps/libPlatformGtk_la-OpenTypeVerticalData.Tpo Source/WebCore/platform/graphics/opentype/.deps/libPlatformGtk_la-OpenTypeVerticalData.Plo
:info:build gmake[1]: Leaving directory '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk3/work/webkitgtk-2.4.8'
:info:build GNUmakefile:25683: recipe for target 'all' failed
:info:build gmake: *** [all] Error 2
:info:build gmake: Leaving directory '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk3/work/webkitgtk-2.4.8'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk3/work/webkitgtk-2.4.8" && /opt/local/bin/gmake -j4 -w all CC="/usr/bin/clang -arch x86_64" V=1 
:info:build Exit code: 2
:error:build org.macports.build for port webkit-gtk3 returned: command execution failed

Attachments (1)

main.log (54.8 KB) - added by life.130815@… 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by life.130815@…

Attachment: main.log added

comment:1 Changed 6 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… devans@… added
Description: modified (diff)
Owner: changed from macports-tickets@… to jeremyhu@…
Port: webkit-gtk3 added
Summary: mac os x 10.10 install webkit-gtk3 failedwebkit-gtk3 @2.4.8_1 build failure

Please don't paste log data into the ticket description, use some WikiFormatting instead. Also fill in some descriptive info as in the guide.

See this thread, possibly related to this ticket that has already been patched, but after 2.4.8 was out.

Matainers: is there a reason this port is 2.4.8 while there are versions 2.6 and 2.8 released?

comment:2 Changed 6 years ago by dbevans (David B. Evans)

Resolution: duplicate
Status: newclosed

Duplicate of #47430 which discusses the issue and has a tentative fix. Please check for existing tickets before submitting a new one.

Concerning later versions: versions 2.6+ abruptly switched to a cmake build system as well as significant refactoring of the code. webkit-gtk 1.0 API is dropped entirely and there are ongoing issues with getting webkit2-gtk to build. Both Jeremy and I have been working on this but no luck as yet and not much help from upstream. It is continues to be a high priority with me.

comment:3 Changed 6 years ago by anddam (Andrea D'Amore)

When this was opened the summary of #47430 was different so it wouldn't come out while looking for webkit-gtk3.

comment:4 in reply to:  3 Changed 6 years ago by dbevans (David B. Evans)

Replying to and.damore@…:

When this was opened the summary of #47430 was different so it wouldn't come out while looking for webkit-gtk3.

True, that's why I changed the summary of the ticket to more closely reflect the true nature of the problem. However it is the same problem and a slightly less restrictive search on webkit-gtk would have revealed the previous tickets.

At any rate, sorry for being grumpy about it.

Note: See TracTickets for help on using tickets.