Opened 5 years ago

Closed 5 years ago

#47547 closed update (fixed)

root6 : Update to 6.03.04

Reported by: cjones051073 (Chris Jones) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: haspatch maintainer Cc: mojca (Mojca Miklavec)
Port: root6

Description

Hi,

Updates ROOT6 to the latest official release.

Adds a new options to use clang 3.7 as the compiler.

I also updated the compiler whitelist to add clang 3.6 as an option, and also to list the compilers such that the most up to date compatible compiler will be used.

I believe the patch to fix an issue with the internal LLVM version is still required, as upstream ROOT have not yet updated the version they are using (the issue is fixed in more recent LLVM tags than the one they currently use...).

cheers Chris

Attachments (1)

root6.diff (3.6 KB) - added by cjones051073 (Chris Jones) 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by cjones051073 (Chris Jones)

Attachment: root6.diff added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

Thanks.

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.