Opened 4 years ago

Closed 2 years ago

#47552 closed defect (worksforme)

swi-prolog-devel @7.1.37 staging failure

Reported by: mf2k (Frank Schima) Owned by: pmoura (Paulo Moura)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: J.Wielemaker@…
Port: swi-prolog-devel

Description

I just tried to update to version 7.1.37 and I see this error:

:info:destroot ERROR: /opt/local/var/macports/build/_opt_mports_trunk_dports_lang_swi-prolog-devel/swi-prolog-devel/work/destroot/opt/local/lib/swipl-7.1.37/xpce/prolog/boot/pce_principal.pl:147:
:info:destroot 	dlopen(pl2xpce, 1): image not found
:info:destroot ERROR: /opt/local/var/macports/build/_opt_mports_trunk_dports_lang_swi-prolog-devel/swi-prolog-devel/work/destroot/opt/local/lib/swipl-7.1.37/xpce/prolog/boot/pce_principal.pl:147:
:info:destroot 	Failed to initialise the XPCE toolkit.  This is normally
:info:destroot 	caused by a missing or incompatible X11 library.
:info:destroot 	See http://www.swi-prolog.org/build/issues/xpce.html
:info:destroot 	Sorry, cannot recover from this.  Process terminates.

Attachments (1)

main.log (318.3 KB) - added by mf2k (Frank Schima) 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:1 Changed 4 years ago by pmoura (Paulo Moura)

I'm unable to reproduce the problem in Mac OS X 10.10.3 with up-to-date X11 libraries.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

I see the issue on OS X 10.9.5.

comment:3 Changed 4 years ago by pmoura (Paulo Moura)

I have no access to Mac OS X 10.9.5. Hopefully the developer of SWI-Prolog would be able to help.

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

Please check whether this is still a problem with 7.5.0. (It built successfully on our buildbot.)

comment:5 Changed 2 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

Yes, it builds fine for me now.

Note: See TracTickets for help on using tickets.