Opened 4 years ago

Closed 12 months ago

#47691 closed defect (fixed)

remove obsolete python variants

Reported by: petrrr Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: graphviz graphviz-devel clang-3.3 xchat2 boost

Description (last modified by yan12125 (Chih-Hsuan Yen))

This ticket intends to remove obsolete python variants, i.e:

  • python24
  • python25
  • python31
  • python32

Ideally +python27 should become the default and is added if missing. Also consider removing +python26 and +python33 variants.

+python{24,25}:

+python25:

+python{25,31,32}:

Without openmaintainer

  • ryandesign : graphviz{,-devel} (r136025)
  • jeremyhu, larryv : clang-3.3

With openmaintainer

Unmaintained:

Attachments (1)

boost.patch (961 bytes) - added by larryv (Lawrence Velázquez) 4 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 years ago by petrrr

Cc: hum@… ryandesign@… jeremyhu@… larryv@… takeshi@… nicos@… khindenburg@… ciserlohn@… pixilla@… aronnax@… raimue@… g5pw@… usx303@… hsivank@… stuartwesterman@… added
Description: modified (diff)

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: hum@… larryv@… takeshi@… nicos@… khindenburg@… ciserlohn@… pixilla@… aronnax@… raimue@… g5pw@… usx303@… hsivank@… stuartwesterman@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to larryv@…
Port: liblinear libsvm libprelude libpreludedb pdflib redland-bindings gnudatalanguage grib_api kross-interpreters LyX magicspp nodejs nodejs-devel plplot plplot-single qtiplot sqlmap telepathy-qt vtk5 wireshark-devel gdb htcondor MacVim vim vim-app xorg-libxcb xorg-xcb-proto coccinelle libsbml removed
Status: newassigned

Nearly all of these are false positives because they contain legacy variants. I have removed these ports and their maintainers.

I retired the 2.4–2.6 variants in graphviz and graphviz-devel in r136025.

comment:3 Changed 4 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)

xchat2 done in r136540.

Changed 4 years ago by larryv (Lawrence Velázquez)

Attachment: boost.patch added

comment:4 Changed 4 years ago by larryv (Lawrence Velázquez)

Ryan, I’ve just attached a patch for boost. Mind if I commit it?

comment:5 Changed 4 years ago by ryandesign (Ryan Schmidt)

Sure, that's fine. Thanks!

comment:6 in reply to:  5 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: ryandesign@… removed
Description: modified (diff)

Great, r136759.

comment:7 Changed 12 months ago by yan12125 (Chih-Hsuan Yen)

In 1b59ebeba1383f1288adf62161e256119283fec1/macports-ports (master):

InsightToolkit{,312,314}: removed in favor of InsightToolkit-devel

The last ITK 3.x release 3.20 is out in 2010, and 4.x have been there
for almost 8 years. I see no reason to keep 3.x around.

Closes: #23772
Closes: #26373
Closes: #33857
Closes: #37894
Closes: #42973
Closes: #45634
Closes: #45670
Ref: #47691

comment:8 Changed 12 months ago by yan12125 (Chih-Hsuan Yen)

Description: modified (diff)
Port: InsightToolkit InsightToolkit312 InsightToolkit314 removed

comment:9 Changed 12 months ago by yan12125 (Chih-Hsuan Yen)

Resolution: fixed
Status: assignedclosed

In 42ac8415292faafb79aa6e9b6b50a8d277feb426/macports-ports (master):

llvm-3.3: drop old Python variants

Closes #47691

Note: See TracTickets for help on using tickets.