Opened 6 years ago

Closed 19 hours ago

#47725 closed defect (worksforme)

shogun: Assumes python is present

Reported by: mf2k (Frank Schima) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: shogun

Description

The shogun Portfile assumes python27 is installed or else it fails with an error.

$ port info shogun
Error: shogun: Error executing python27: couldn't execute "/opt/local/bin/python2.7": no such file or directory
Error: Unable to open port: Error evaluating variants

Attachments (1)

main.log (86.1 KB) - added by mf2k (Frank Schima) 6 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by larryv (Lawrence Velázquez)

Try wrapping this…

set py_prefix \[python_prefix\]
configure.args-append   --python=${prefix}/bin/python${v} \
                        --pydir=\${py_prefix}/lib/python${v}/site-packages \
                        --includes=\${py_prefix}/include/python${v}

… in a pre-configure script.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

That fixed the port info error, but it failed to build for me. I don't know if that is the cause or if that's a normal failure.

Changed 6 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:3 Changed 19 hours ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

I cannot reproduce this now.

Note: See TracTickets for help on using tickets.