Opened 4 years ago

Closed 4 years ago

#47790 closed update (fixed)

pstree: update to 2.39

Reported by: janstary (Jan Starý) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: larryv (Lawrence Velázquez), ryandesign (Ryan Schmidt)
Port: pstree

Description

Update pstree to version 2.39:

  • instead of a ./configure that >>'s a Makefile, have minimal Makefile and set use_configure no
  • drop the destroot commands in Portfile and just make destroot with the Makefile
  • pstree has a manpage, so just install that instead of copying the README

Attachments (2)

Portfile.diff (1.8 KB) - added by janstary (Jan Starý) 4 years ago.
update pstree to 2.39
Makefile (172 bytes) - added by janstary (Jan Starý) 4 years ago.
provide a minimal Makefile as pstree doesn't have one

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by janstary (Jan Starý)

Attachment: Portfile.diff added

update pstree to 2.39

Changed 4 years ago by janstary (Jan Starý)

Attachment: Makefile added

provide a minimal Makefile as pstree doesn't have one

comment:1 Changed 4 years ago by janstary (Jan Starý)

I am not sure how to reflect the removal of files/configure in my patch.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: mww@… removed
Owner: changed from macports-tickets@… to mww@…
Version: 2.3.3

comment:3 Changed 4 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed
Summary: update pstree to 2.39pstree: update to 2.39

I've updated pstree to 2.39 in r137283, but I haven't made all the changes you proposed, because many of them are regressions.

For example, pstree does not install any libraries, and it correctly indicates this via the line installs_libs no, but your patch removes this line. There are no ports that depend on pstree, so it doesn't really affect anything, but since the port maintainer has already gone out of his way to indicate that the port does not install libraries, there's no reason to remove this indication.

The existing configure script records the values of the CC, CFLAGS and LDFLAGS variables into the Makefile and uses them at build time, which means it's UsingTheRightCompiler and -arch flags. Your proposed change doesn't do any of this, so a wrong compiler might be used, and the build will always use the compiler's default architecture even if the user requested something different.

The README should still be installed, even if there is also a manpage.

I did apply some of your other changes: r137280 r137281

I also made some additional changes of my own: r137279 r137282

Note: See TracTickets for help on using tickets.