Opened 5 years ago

Closed 5 years ago

#47926 closed defect (fixed)

py34-stfio import error

Reported by: rrifkin600@… Owned by: neurodroid (Christoph Schmidt-Hieber)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: larryv (Lawrence Velázquez)
Port: py34-stfio

Description (last modified by ryandesign (Ryan Schmidt))

In python 3.4, importing the library stfio causes the following error:

$ python
Python 3.4.3 (default, May 25 2015, 18:48:21) 
[GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.56)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import stfio
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/__init__.py", line 6, in <module>
    from .stfio import *
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/stfio.py", line 33, in <module>
    _stfio = swig_import_helper()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/stfio.py", line 29, in swig_import_helper
    _mod = imp.load_module('_stfio', fp, pathname, description)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/imp.py", line 243, in load_module
    return load_dynamic(name, filename, file)
ImportError: dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/_stfio.so, 2): Symbol not found: __ZNKSt3__19basic_iosIcNS_11char_traitsIcEEE5widenEc
  Referenced from: /opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/libstfio.dylib
  Expected in: flat namespace
 in /opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/libstfio.dylib

I need to use this library so I would appreciate your help very much.

Thank you very much, Robert

Change History (10)

comment:1 Changed 5 years ago by rrifkin600@…

Cc: rrifkin600@… added

Cc Me!

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: rrifkin600@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to christsc@…

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Yes, I can reproduce that issue on my Yosemite machine.

comment:4 Changed 5 years ago by neurodroid (Christoph Schmidt-Hieber)

Seems to be related to the C++ library that is being used. The problem disappears when clang is replaced with g++-mp-4.9.

comment:5 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:6 in reply to:  3 Changed 5 years ago by neurodroid (Christoph Schmidt-Hieber)

Replying to ryandesign@…:

Yes, I can reproduce that issue on my Yosemite machine.

What's the right way to address this issue? Should I set configure.compiler to macports-gcc?

comment:7 Changed 5 years ago by neurodroid (Christoph Schmidt-Hieber)

This problem has mysteriously disappeared on my system after doing

sudo port selfupdate
sudo port upgrade -u outdated
sudo port -n upgrade --force py27-stfio py34-stfio

Can anyone else confirm?

comment:8 in reply to:  7 ; Changed 5 years ago by larryv (Lawrence Velázquez)

I still get an error, but it’s probably unrelated to this ticket.

% python3.4
Python 3.4.3 (default, May 25 2015, 21:55:17) 
[GCC 4.2.1 Compatible Apple LLVM 6.1.0 (clang-602.0.53)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import stfio
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/__init__.py", line 7, in <module>
    from . import stfio_plot as plot
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/stfio_plot.py", line 211, in <module>
    class StandardAxis(Subplot):
NameError: name 'Subplot' is not defined

Perhaps the original issue was caused by the faulty HDF5 1.8.15 release that was fixed in r137065? GDAL had an issue that has similarly cleared up (#47758).

comment:9 in reply to:  8 ; Changed 5 years ago by neurodroid (Christoph Schmidt-Hieber)

Replying to larryv@…:

I still get an error, but it’s probably unrelated to this ticket.

% python3.4
Python 3.4.3 (default, May 25 2015, 21:55:17) 
[GCC 4.2.1 Compatible Apple LLVM 6.1.0 (clang-602.0.53)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import stfio
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/__init__.py", line 7, in <module>
    from . import stfio_plot as plot
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/stfio/stfio_plot.py", line 211, in <module>
    class StandardAxis(Subplot):
NameError: name 'Subplot' is not defined

Thanks for the report - I'll have to add py${python.version}-matplotlib to the dependencies

Perhaps the original issue was caused by the faulty HDF5 1.8.15 release that was fixed in r137065? GDAL had an issue that has similarly cleared up (#47758).

Yes that seems likely.

comment:10 in reply to:  9 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: newclosed

Okay, we’ll call this fixed by r137065.

Note: See TracTickets for help on using tickets.