Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#47958 closed update (fixed)

plplot @5.10.0_3: update to 5.11.0

Reported by: Schamschula (Marius Schamschula) Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: dbevans (David B. Evans), cdeil (Christoph Deil), pj31042@…
Port: plplot

Description

plplot has been updated to version 5.11.0. See https://sourceforge.net/p/plplot/news/2015/04/plplot-5110-has-been-released/ for details. The existing patch files have been included upstream. patch-cmake-modules-pkg-config.cmake.diff fixes a new issue.

Note: This update breaks gnudatalanguage @0.9.5_5. I was able top fix the name change of the plplot dylibs (see patch-CMakeModules-FindPlplot.cmake.diff) but then got a build error.

Attachments (3)

Portfile-plplot.diff (1.5 KB) - added by Schamschula (Marius Schamschula) 6 years ago.
patch-cmake-modules-pkg-config.cmake.diff (409 bytes) - added by Schamschula (Marius Schamschula) 6 years ago.
patch-CMakeModules-FindPlplot.cmake.diff (509 bytes) - added by Schamschula (Marius Schamschula) 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-plplot.diff added

Changed 6 years ago by Schamschula (Marius Schamschula)

Changed 6 years ago by Schamschula (Marius Schamschula)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: takeshi@… removed
Owner: changed from macports-tickets@… to takeshi@…
Version: 2.3.3

comment:2 Changed 6 years ago by tenomoto (Takeshi Enomoto)

Thanks for working on this. I reported the problem to the developer of GDL.

comment:3 Changed 6 years ago by dbevans (David B. Evans)

Cc: devans@… added

Cc Me!

comment:4 Changed 6 years ago by dbevans (David B. Evans)

p5-pdl-graphics-plplot @0.710.0 (current version) claims to be compatible with plplot 5.11.0

0.71 5/15/2015   Added patch from Petr Pisar to allow build with plplot 5.11.0.  Deferred call to plschr() until
                 after call to plinit().  Response to CPAN bug: https://rt.cpan.org/Public/Bug/Display.html?id=104424

Will test with your patches and let you know. Thanks for the heads-up.

comment:5 Changed 6 years ago by dbevans (David B. Evans)

Confirming that p5-pdl-graphics-plplot configures and builds correctly using plplot 5.11.0 built as specified in this ticket. Just needs a revbump to force rebuild after plplot is updated.

comment:6 Changed 6 years ago by cdeil (Christoph Deil)

Cc: Deil.Christoph@… added

Cc Me!

comment:7 Changed 6 years ago by pj31042@…

Cc: pj31042@… added

Cc Me!

comment:8 Changed 6 years ago by pj31042@…

Thanks for the heads up. Svndigest has come out with a new release to work also against plplot 5.11 (#48722).

comment:9 Changed 6 years ago by tenomoto (Takeshi Enomoto)

I am going to see one of the developer of GDL in person on Monday. After that I'll decide if I should split plplot or not.

comment:10 Changed 6 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed

plplot is updated to 5.11.1 in r140025 and rev-bump done in r140026.

comment:11 Changed 6 years ago by tenomoto (Takeshi Enomoto)

I revised plplot510 and gnudatalanguage to avoid conflict with plplot by changing to the install base of plplot510 to ${prefix}/lib/plplot510 in r140034.

Note: See TracTickets for help on using tickets.