Opened 4 years ago

Closed 4 years ago

#47964 closed defect (fixed)

MacVim @7.4.snapshot76_1 wrong directory name

Reported by: rlmaers (Rafael Lukas Maers) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: macvim

Description (last modified by neverpanic (Clemens Lang))

# port upgrade macvim
--->  Computing dependencies for MacVim
--->  Fetching archive for MacVim
--->  Attempting to fetch MacVim-7.4.snapshot76_1+huge+python27.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/MacVim
--->  Attempting to fetch MacVim-7.4.snapshot76_1+huge+python27.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/MacVim
--->  Attempting to fetch MacVim-7.4.snapshot76_1+huge+python27.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/MacVim
--->  Fetching distfiles for MacVim
--->  Verifying checksums for MacVim
--->  Extracting MacVim
--->  Applying patches to MacVim
Error: org.macports.patch for port MacVim returned: command execution failed
Please see the log file for port MacVim for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_MacVim/MacVim/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

See attached main.log. The cause of the problem is that Snapshot-76.tar.gz extracts macvim-Snapshot-76 and not MacVim-Snapshot-76, such that the file which is to be patched does not exist. This is primarily a problem for users with case sensitive file systems.

Attachments (1)

main.log (8.2 KB) - added by rlmaers (Rafael Lukas Maers) 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by rlmaers (Rafael Lukas Maers)

Attachment: main.log added

comment:1 Changed 4 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Owner: changed from macports-tickets@… to raimue@…

Please use WikiFormatting, preview your post, and Cc the maintainer when reporting bugs against ports.

comment:2 Changed 4 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Thanks for the report.

Fixed in r137154.

Note: See TracTickets for help on using tickets.