Opened 5 years ago

Last modified 17 months ago

#48064 assigned defect

py27-astropy fails in build stage on G4 running Leopard 10.5.8

Reported by: zanderpower@… Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: leopard powerpc Cc:
Port: py-astropy

Description

The error message is

:info:build ld: absolute addressing (perhaps -mdynamic-no-pic) used in _celini from /mp2/local/lib/libwcs.a(cel.o) not allowed in slidable image. Use '-read_only_relocs suppress' to enable text relocs
:info:build collect2: ld returned 1 exit status
:info:build error: command '/usr/bin/gcc-4.2' failed with exit status 1
:info:build Command failed:  cd "/mp2/local/var/macports/build/

However, it builds and installs without error if I comment out the line

--use-system-wcslib

in its Portfile.

I am fairly confident that this is related to the way I installed wcslib: as wcslib failed in the destroot phase, I added the line

configure.ldflags-append        "read_only_relocs suppress"

to _its_ Portfile. See ticket #48047.

Note that py27-astropy fails with the same error as wcslib did. I tried adding "read_only_relocs suppress" to py27-astropy's Portfile, but no luck.

Attachments (1)

main.log (244.9 KB) - added by zanderpower@… 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by zanderpower@…

Attachment: main.log added

comment:1 Changed 5 years ago by zanderpower@…

Let me correct myself: py27-astropy fails with an error similar to the one I saw in wcslib. However, wcslib failed in destroot, unlike py27-astropy which failed during build.

comment:2 Changed 5 years ago by zanderpower@…

Tried

configure.ldflags-append        -read_only_relocs suppress

(without the quotation marks) and still no go.

comment:3 Changed 5 years ago by mf2k (Frank Schima)

Cc: robitaille@… removed
Keywords: powerpc added; "read_only_relocs suppress" removed
Owner: changed from macports-tickets@… to robitaille@…
Port: py-astropy added; py27-astropy removed

comment:4 Changed 17 months ago by kurthindenburg (Kurt Hindenburg)

Owner: robitaille@… deleted
Status: newassigned
Note: See TracTickets for help on using tickets.