Opened 4 years ago

Closed 3 years ago

#48076 closed update (fixed)

tor-devel @0.2.6.3-alpha_3: update to 0.2.7.1-alpha

Reported by: rjt-macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: tor-devel

Description

Tor's development branch is at 0.2.7.1-alpha now. Release notes: https://blog.torproject.org/blog/tor-0271-alpha-released

Attachments (1)

patch_tor-devel-0.2.6.3-alpha_tor-devel-0.2.7.1-alpha-released-20150512.txt (1.1 KB) - added by rjt-macports@… 4 years ago.
Patch for Portfile to update tor-devel from 0.2.6.3-alpha to 0.2.7.1-alpha

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by rjt-macports@…

Patch for Portfile to update tor-devel from 0.2.6.3-alpha to 0.2.7.1-alpha

comment:1 Changed 4 years ago by rjt-macports@…

I've been using this version on a tor exit node for 2 weeks without any noticeable problems caused by the update

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

Keywords: haspatch added
Summary: tor-devel 0.2.7.1-alpha update from 0.2.6.3-alphator-devel @0.2.6.3-alpha_3: update to 0.2.7.1-alpha
Version: 2.3.3

Why did you remove the dist_subdir line?

comment:3 Changed 4 years ago by rjt-macports@…

The homepage URI https://www.torproject.org/, when used for master_sites as ${homepage}dist/ (AKA https://www.torproject.org/dist/), redirects to https://dist.torproject.org/ where the tor-0.2.7.1-alpha.tar.gz file is found.

If we build https://www.torproject.org/dist/tor/ we get a 404 since there is no tor directory at https://dist.torproject.org/

Might it be better to replace master_sites directly with https://dist.torproject.org/ rather than referencing ${homepage}?

comment:4 Changed 3 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: newclosed

Port got updated to a version newer than requested in r143008.

Note: See TracTickets for help on using tickets.