Opened 5 years ago

Closed 12 days ago

#48126 closed defect (fixed)

wgrib2 @2.0.0_3: build fails, cannot find _omp_set_num_threads and restGPRx

Reported by: zanderpower@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: chrstphrchvz (Christopher Chavez)
Port: wgrib2

Description

Please disregard dup. Stupid joke made me forget to CC the maintainer.

Attachments (1)

main.log (264.8 KB) - added by zanderpower@… 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by zanderpower@…

Attachment: main.log added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: takeshi@… removed
Owner: changed from macports-tickets@… to takeshi@…
Summary: build failure: wgrib cannot find libipolate.awgrib2 @2.0.0_3: build fails, cannot find _omp_set_num_threads and restGPRx

comment:2 Changed 5 years ago by zanderpower@…

Just checking back with you to see if you have had time to look over this ticket. (I know that you are very busy.) ;-)

comment:3 Changed 5 years ago by tenomoto (Takeshi Enomoto)

Sorry for slow response. I looked at main.log. You are trying to build wgrib2 on Leopard PPC. The problem is that gcc-4.2, which is the default for Leopard, is used to compile the source, but OpenMP is enabled. gcc-4.2 does not support OpenMP. I think I can fix this. I'll test the fix on a Power Mac.

comment:4 Changed 5 years ago by zanderpower@…

No hurries. Just checking back in. I also wanted to add that the reason I need wgrib2 is so I can build ncarg. You may know of other problems I might experience, as I see that you maintain ncarg as well.

comment:5 Changed 4 months ago by chrstphrchvz (Christopher Chavez)

I believe this can be closed, since wgrib2 has been using a compiler whitelist to ensure OpenMP support for some time: [dacf527051/macports-ports]

comment:6 Changed 4 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:7 Changed 12 days ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.