Opened 5 years ago

Closed 5 years ago

#48141 closed enhancement (duplicate)

"port select" should link manpages

Reported by: cwbrune@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port:

Description

port select makes it easy for a user to manage multiple versions of a port. However, there is no symbolic link in /opt/local/share/man corresponding to that in /opt/local/bin. For example, after typing port select gcc mp-gcc49, the command gcc runs the selected version. However, man gcc says "No manual entry for gcc."

Selecting a version using port select should also make appropriate symbolic links so the manpage for the selected version is displayed when man <group> is given.

Change History (1)

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Component: baseports
Keywords: select version manpage removed
Milestone: MacPorts Future
Resolution: duplicate
Status: newclosed
Type: requestenhancement

The port select mechanism can already link anything; it’s up to the individual *_select ports to specify which files to link. For instance, the python, python2, and python3 groups do link man pages.

Duplicate of #29752, which I’ll expand to cover all select groups.

Note: See TracTickets for help on using tickets.