Opened 5 years ago

Closed 5 years ago

#48150 closed enhancement (duplicate)

hdf5 @1.8.15-patch1: unsupported variant combinations to be handled smoothly

Reported by: petrrr Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: seanfarley (Sean Farley)
Port: hdf5 openmpi

Description

The following combination of variants is not handled smoothly:

+cxx +fortran +gcc{5,6} +openmpi +szip

I'd propose that either the missing dependencies (openmpi-gcc{5,6}) are added, or that the hdf5 port handles this combination explicitly.

petr% sudo port -v install hdf5 +cxx +fortran +gcc5 +openmpi +szip
--->  Computing dependencies for hdf5.
Error: Dependency 'openmpi-gcc5' not found.
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port hdf5 failed

Change History (4)

comment:1 Changed 5 years ago by mamoll (Mark Moll)

IMO, this should be fixed in the compilers port group. Any other port that uses openmpi and gcc{5,6} will run into this problem.

comment:2 Changed 5 years ago by larryv (Lawrence Velázquez)

Yes, openmpi-gcc5 and openmpi-gcc6 do not exist. See #48091.

comment:3 Changed 5 years ago by petrrr

Okay, so let's close this and get #48091 solved.

comment:4 Changed 5 years ago by mamoll (Mark Moll)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.