Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#48167 closed defect (duplicate)

llvm-3.3 @3.3_8 fails configuring

Reported by: udbraumann Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), larryv (Lawrence Velázquez)
Port: llvm-3.3

Description

Upgrading llvm-3.3 @3.3_7 to llvm-3.3 @3.3_8 fails since the configure script by mistake is not recognizing that python has an accepted version.

The relevant lines in the config.log:

...
configure:12343: checking for python
configure:12361: found /opt/local/bin/python
configure:12378: result: /opt/local/bin/python
configure:12388: checking for python >= 2.5
configure:12399: result: not found
configure:12402: error: found python  (/opt/local/bin/python); required >= 2.5
...

However, manually checking the version gives:

$ /opt/local/bin/python --version
Python 3.4.3

BTW, llvm-3.4 was smoothly upgrading to llvm-3.4 @3.4.2_7 a minute before.

Attachments (1)

main.log (21.5 KB) - added by udbraumann 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by udbraumann

Attachment: main.log added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Duplicate of #32575. A workaround:

% sudo port select --set python none
% sudo port upgrade llvm-3.3
% sudo port select --set python python34

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Keywords: python version check fails removed

comment:3 in reply to:  1 Changed 5 years ago by udbraumann

Thanks, trick has worked fine :-)

Note: See TracTickets for help on using tickets.