Opened 5 years ago

Closed 5 years ago

#48179 closed defect (worksforme)

can not port anything

Reported by: swen@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.3.3
Keywords: Cc:
Port:

Description (last modified by ryandesign (Ryan Schmidt))

Hi,I installed macport on my desktop which I do not have root access. The configure I used is:

./configure --prefix=/Users/wen/macport --with-no-root-privileges --with-install-user=wen --with-macports-user=wen --with-install-group=nogroup

after installing MacPort, I tried to use it to port cmake and qt5, but it can not find cmake:

hollyhock:bin wen6$ port install cmake
Error: Port cmake not found

It happens to others too, qt5, vim...

I tried to update the tree, but I get the error:

hollyhock:bin wen6$ port sync
--->  Updating the ports tree
Error: Synchronization of the local ports tree failed doing rsync
port sync failed: Synchronization of 1 source(s) failed

Can you help me so I can use MacPort?

Change History (4)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Priority: HighNormal

The Priority field is for use by Macports team members only.

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Description: modified (diff)

The reason why cmake and other ports are not found is that your ports tree probably doesn't exist, so you need to run port sync to create it.

Run port -v sync to see why the sync failed.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Have you made any progress? What happened when you ran port -v sync?

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

If you need further help using MacPorts, please write to the macports-users mailing list.

Note: See TracTickets for help on using tickets.