Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#48261 closed defect (duplicate)

volk @2.3.3 command excecution failed

Reported by: fluzzygib@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: volk

Description (last modified by ryandesign (Ryan Schmidt))

I'm trying to install GQRX on my MacBook Pro for using a software defined radio on my computer, yet it got held up at installing volk. It at first said I needed to install some other things which I went in and installed by typing sudo port install this that this that and that and I got down to all but 4 things that needed volk as well. I also made sure to install all of volk's dependencies. Now, I'm completely stopped. I've ran the clean stuff twice on volk and GQRX, tried to install again and got caught here.

Any help? This is what I get when I type the gqrx stuff now:

Dannys-MacBook-Pro:~ Dan$ sudo port install gqrx
--->  Computing dependencies for gqrx
--->  Dependencies to be installed: gnuradio volk gr-osmosdr gr-fcdproplus
--->  Building volk
Error: org.macports.build for port volk returned: command execution failed
Error: Failed to install volk
Please see the log file for port volk for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_volk/volk/main.log
Error: The following dependencies were not installed: gnuradio volk gr-osmosdr gr-fcdproplus
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gqrx failed
Dannys-MacBook-Pro:~ Dan$ 

Could it be that I have not yet connected an airspy receiver to my computer? It is not yet at my house but I want to install it beforehand.

Attachments (1)

main.log (149.1 KB) - added by fluzzygib@… 5 years ago.
Main.log as requested

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: volk removed
Owner: changed from macports-tickets@… to michaelld@…

Please run "sudo port clean volk", then try again. If it fails again, please attach the main.log file so that we can see why it failed to build.

Changed 5 years ago by fluzzygib@…

Attachment: main.log added

Main.log as requested

comment:2 Changed 5 years ago by fluzzygib@…

I ran the command for clean and got all the way to "building volk" this time. Still failed after the clean:

---> Cleaning volk Dannys-MacBook-Pro:~ Dan$ sudo port install gqrx ---> Computing dependencies for gqrx ---> Dependencies to be installed: gnuradio volk gr-osmosdr gr-fcdproplus ---> Fetching archive for volk ---> Attempting to fetch volk-20150523_0+docs+orc.darwin_11.x86_64.tbz2 from http://packages.macports.org/volk ---> Attempting to fetch volk-20150523_0+docs+orc.darwin_11.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/volk ---> Attempting to fetch volk-20150523_0+docs+orc.darwin_11.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/volk ---> Fetching distfiles for volk ---> Verifying checksums for volk ---> Extracting volk ---> Applying patches to volk ---> Configuring volk ---> Building volk Error: org.macports.build for port volk returned: command execution failed Error: Failed to install volk Please see the log file for port volk for details:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_volk/volk/main.log

Error: The following dependencies were not installed: gnuradio volk gr-osmosdr gr-fcdproplus To report a bug, follow the instructions in the guide:

http://guide.macports.org/#project.tickets

Error: Processing of port gqrx failed Dannys-MacBook-Pro:~ Dan$

comment:3 Changed 5 years ago by michaelld (Michael Dickens)

Resolution: duplicate
Status: newclosed

Duplicate of #48009.

comment:4 Changed 5 years ago by michaelld (Michael Dickens)

My recommendation for older OSs such as yours is to update to the latest Xcode, clean volk, then try again. Older Apple Clang has detection issues, since it tries to mimic GCC in various ways.

Note: See TracTickets for help on using tickets.