Opened 5 years ago

Closed 5 years ago

#48266 closed defect (fixed)

gnudatalanguage, pslib: dyld: symbol not found

Reported by: jaymurthy Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: gnudatalanguage, pslib

Description (last modified by ryandesign (Ryan Schmidt))

Updated ports and gdl is now failing:

$gdl
dyld: lazy symbol binding failed: Symbol not found: _libintl_setlocale
  Referenced from: /opt/local/lib/libps.0.dylib
  Expected in: flat namespace

dyld: Symbol not found: _libintl_setlocale
  Referenced from: /opt/local/lib/libps.0.dylib
  Expected in: flat namespace

Trace/BPT trap: 5

Change History (5)

comment:1 Changed 5 years ago by jaymurthy

Cc: jmurthy@… added

Cc Me!

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; jmurthy@… removed
Description: modified (diff)
Keywords: gnudatalanguage removed
Owner: changed from macports-tickets@… to takeshi@…
Port: pslib added
Summary: dyld: symbol not foundgnudatalanguage, pslib: dyld: symbol not found

The mention of the flat namespace is suspicious, since the flat namespace is not generally used on Mac OS X 10.3 or later. It suggests that pslib is subject to what we've been calling the Yosemite libtool bug, wherein configure scripts generated with old versions of libtool incorrectly interpret OS X 10.10 and later as if they were OS X 10.1 and consequently use old flags. A simple patch to the configure script, and a revbump, fixes this, though I don't know if it's the cause of the error you're seeing.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

I've fixed pslib to use the two-level namespace instead of the flat namespace in r138364. If you wait 30 minutes, then "sudo port selfupdate" and "sudo port upgrade outdated", does that help?

comment:4 Changed 5 years ago by jaymurthy

No luck. It picked up the changes but the same errors as before.

comment:5 Changed 5 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed

I was able to reproduce the problem. I was able to fix this by adding -lintl to configure.ldflags. Thanks for reporting.

Note: See TracTickets for help on using tickets.