Opened 5 years ago

Last modified 5 years ago

#48267 new defect

gnudatalange @0.9.5_4: dyld: Library not loaded: /opt/local/lib/libgrib_api.0.dylib

Reported by: ryandesign (Ryan Schmidt) Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: gnudatalanguage

Description

gdl fails to run:

$ gdl
dyld: Library not loaded: /opt/local/lib/libgrib_api.0.dylib
  Referenced from: /opt/local/bin/gdl
  Reason: image not found
Trace/BPT trap: 5

I have libgrib_api.dylib but not libgrib_api.0.dylib:

$ port contents grib_api | grep dylib$
  /opt/local/lib/libgrib_api.dylib
$ port -v installed gnudatalanguage grib_api
The following ports are currently installed:
  gnudatalanguage @0.9.5_4+universal (active) platform='darwin 14' archs='i386 x86_64'
  grib_api @1.13.1_1+universal platform='darwin 14' archs='i386 x86_64'
  grib_api @1.13.1_3+universal-gcc5 (active) platform='darwin 14' archs='i386 x86_64'

Change History (1)

comment:1 Changed 5 years ago by tenomoto (Takeshi Enomoto)

I confirmed that there is no libgrib_api.0.dylib. I tried to reproduce the problem by compiling with +universal, but I was unable to build gobject-introspection +universal.

Note: See TracTickets for help on using tickets.