Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#48314 closed defect (fixed)

gettext @0.19.5_0: Undefined symbols: "_stpncpy"

Reported by: ballapete (Peter Dyballa) Owned by: ryandesign (Ryan Schmidt)
Priority: High Milestone:
Component: ports Version: 2.3.3
Keywords: tiger leopard snowleopard Cc: udbraumann, gnw3, nerdling (Jeremy L), attie.raphael@…, bitpup, floehlj@…, jeremyhu (Jeremy Huddleston Sequoia)
Port: gettext

Description

/bin/sh ../libtool  --tag=CC   --mode=link /opt/local/bin/gcc-apple-4.2 -std=gnu99  -pipe -Os -arch ppc -version-info 5:3:5 -rpath /opt/local/lib ../intl/libintl.la -L/opt/local/lib -liconv -R/opt/local/lib  -Wl,-framework -Wl,CoreFoundation -L/opt/local/lib -liconv -R/opt/local/lib -L/opt/local/lib -lexpat -R/opt/local/lib -lc -no-undefined  -L/opt/local/lib -Wl,-headerpad_max_install_names -arch ppc -o libgettextpo.la -rpath /opt/local/lib gettext-po.lo ../src/str-list.lo ../src/dir-list.lo ../src/message.lo ../src/msgl-ascii.lo ../src/po-error.lo ../src/po-xerror.lo ../src/write-catalog.lo ../src/write-po.lo ../src/open-catalog.lo ../src/po-charset.lo ../src/po-lex.lo ../src/po-gram-gen.lo ../src/read-po.lo ../src/read-catalog-abstract.lo ../src/read-catalog.lo ../src/plural-table.lo ../src/format-c.lo ../src/format-sh.lo ../src/format-python.lo ../src/format-python-brace.lo ../src/format-lisp.lo ../src/format-elisp.lo ../src/format-librep.lo ../src/format-scheme.lo ../src/format-java.lo ../src/format-javascript.lo ../src/format-csharp.lo ../src/format-awk.lo ../src/format-pascal.lo ../src/format-ycp.lo ../src/format-tcl.lo ../src/format-perl.lo ../src/format-perl-brace.lo ../src/format-php.lo ../src/format-gcc-internal.lo ../src/format-gfc-internal.lo ../src/format-qt.lo ../src/format-qt-plural.lo ../src/format-kde.lo ../src/format-kde-kuit.lo ../src/format-boost.lo ../src/format-lua.lo ../src/format.lo ../src/plural-exp.lo ../src/plural-eval.lo ../src/msgl-check.lo ../src/sentence.lo ../src/libexpat-compat.lo  libgnu.la   
libtool: link: /opt/local/bin/gcc-apple-4.2 -std=gnu99 -dynamiclib  -o .libs/libgettextpo.0.dylib  .libs/gettext-po.o ../src/.libs/str-list.o ../src/.libs/dir-list.o ../src/.libs/message.o ../src/.libs/msgl-ascii.o ../src/.libs/po-error.o ../src/.libs/po-xerror.o ../src/.libs/write-catalog.o ../src/.libs/write-po.o ../src/.libs/open-catalog.o ../src/.libs/po-charset.o ../src/.libs/po-lex.o ../src/.libs/po-gram-gen.o ../src/.libs/read-po.o ../src/.libs/read-catalog-abstract.o ../src/.libs/read-catalog.o ../src/.libs/plural-table.o ../src/.libs/format-c.o ../src/.libs/format-sh.o ../src/.libs/format-python.o ../src/.libs/format-python-brace.o ../src/.libs/format-lisp.o ../src/.libs/format-elisp.o ../src/.libs/format-librep.o ../src/.libs/format-scheme.o ../src/.libs/format-java.o ../src/.libs/format-javascript.o ../src/.libs/format-csharp.o ../src/.libs/format-awk.o ../src/.libs/format-pascal.o ../src/.libs/format-ycp.o ../src/.libs/format-tcl.o ../src/.libs/format-perl.o ../src/.libs/format-perl-brace.o ../src/.libs/format-php.o ../src/.libs/format-gcc-internal.o ../src/.libs/format-gfc-internal.o ../src/.libs/format-qt.o ../src/.libs/format-qt-plural.o ../src/.libs/format-kde.o ../src/.libs/format-kde-kuit.o ../src/.libs/format-boost.o ../src/.libs/format-lua.o ../src/.libs/format.o ../src/.libs/plural-exp.o ../src/.libs/plural-eval.o ../src/.libs/msgl-check.o ../src/.libs/sentence.o ../src/.libs/libexpat-compat.o   -Wl,-force_load,./.libs/libgnu.a  ../intl/.libs/libintl.dylib -L/opt/local/lib /opt/local/lib/libexpat.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_gettext/gettext/work/gettext-0.19.5/gettext-tools/intl/.libs/libintl.dylib -lc /opt/local/lib/libiconv.dylib  -Os -arch ppc -Wl,-framework -Wl,CoreFoundation -Wl,-headerpad_max_install_names -arch ppc   -install_name  /opt/local/lib/libgettextpo.0.dylib -compatibility_version 6 -current_version 6.3 -Wl,-single_module
Undefined symbols:
  "_stpncpy", referenced from:
      _format_parse in format-kde-kuit.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[5]: *** [libgettextpo.la] Error 1
make[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_gettext/gettext/work/gettext-0.19.5/gettext-tools/libgettextpo'

Attachments (2)

main.log (1.1 MB) - added by ballapete (Peter Dyballa) 5 years ago.
main.log
main.2.log (1.0 MB) - added by attie.raphael@… 5 years ago.
main.log for gettext failure under snow leopard

Change History (22)

Changed 5 years ago by ballapete (Peter Dyballa)

Attachment: main.log added

main.log

comment:1 Changed 5 years ago by ballapete (Peter Dyballa)

When I try to

port -vd upgrade gcc48 gcc49

why is port

--->  Computing dependencies for gettext

?

comment:2 in reply to:  1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Replying to Peter_Dyballa@…:

Undefined symbols:
  "_stpncpy", referenced from:
      _format_parse in format-kde-kuit.o
ld: symbol(s) not found

I'll check if this happens on my older systems too.

Replying to Peter_Dyballa@…:

When I try to

port -vd upgrade gcc48 gcc49

why is port

--->  Computing dependencies for gettext

?

Because gettext is in the recursive dependencies of gcc48 and gcc49, and MacPorts always upgrades dependencies first. One example: gcc48 and gcc49 both have a library dependency on mpfr, which has an extract dependency on xz, which has a library dependency on gettext.

comment:3 Changed 5 years ago by udbraumann

Cc: braumann@… added

Cc Me!

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Keywords: tiger leopard snowleopard added
Owner: changed from macports-tickets@… to ryandesign@…
Priority: NormalHigh
Status: newassigned
Summary: gettext-0.19.5 does not build on PPC Tiger (Mac OS X 10.4.11) because of Undefined symbol: "_stpncpy"gettext @0.19.5_0: Undefined symbols: "_stpncpy"

Has duplicate #48315. I confirmed the issue on Leopard and Snow Leopard. I filed a bug report with the developers: https://savannah.gnu.org/bugs/?45527

comment:5 Changed 5 years ago by gnw3

Cc: gnwiii@… added

Cc Me!

comment:6 Changed 5 years ago by nerdling (Jeremy L)

Cc: snc@… added

Cc Me!

comment:7 Changed 5 years ago by nerdling (Jeremy L)

We've implemented strnlen for old platforms as well. Is a similar fix sufficient for this port? It might even exist elsewhere in dports already.

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

No, because here stpncpy is already implemented, it just isn't being used at this particular place.

comment:9 Changed 5 years ago by attie.raphael@…

Cc: attie.raphael@… added

Cc Me!

Changed 5 years ago by attie.raphael@…

Attachment: main.2.log added

main.log for gettext failure under snow leopard

comment:10 Changed 5 years ago by attie.raphael@…

Similar problem here (just added main.2.log) after trying to install gcc 4.9 with

sudo port install gcc49

Failure occurs in gettext, with Undefined symbols: "_stpncpy" according to my main.log.

I also tried

sudo port install gettext

same issue.

comment:11 Changed 5 years ago by bitpup

Cc: wheeltong@… added

Cc Me!

comment:12 Changed 5 years ago by floehlj@…

Cc Me!

comment:13 Changed 5 years ago by floehlj@…

Cc: floehlj@… added
Last edited 5 years ago by floehlj@… (previous) (diff)

comment:14 Changed 5 years ago by larryv (Lawrence Velázquez)

Jeremy seems to have fixed this in r138553.

comment:15 in reply to:  14 Changed 5 years ago by udbraumann

Jeremy seems to have fixed this in r138553.

Can confirm that this fix works on 10.6.8. Thanks to Jeremy!

comment:16 Changed 5 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed

comment:17 in reply to:  14 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu@… added

Replying to larryv@…:

Jeremy seems to have fixed this in r138553.

Thanks Jeremy.

Looks like upstream fixed it a different way but I'm happy whichever way it's fixed.

comment:18 in reply to:  14 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Replying to larryv@…:

Jeremy seems to have fixed this in r138553.

This introduces a circular dependency (gettext depends on autoconf which depends on gettext; see #48332) so we need a different fix.

comment:19 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Eh, I'll handle it in #48332.

comment:20 Changed 5 years ago by ballapete (Peter Dyballa)

On PPC Tiger, Mac OS X 10.4.11, the build succeeded today.

Note: See TracTickets for help on using tickets.